summarylogtreecommitdiffstats
path: root/dkms.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dkms.patch')
-rw-r--r--dkms.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dkms.patch b/dkms.patch
new file mode 100644
index 000000000000..05037f052069
--- /dev/null
+++ b/dkms.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 25e5a49..d0a34a2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,11 +7,14 @@ netcat-y+= tracks/trk4.o
+ netcat-y+= tracks/trk5.o
+ netcat-y+= tracks/trk6.o
+
+-KERNELDIR ?= /lib/modules/$(shell uname -r)/build
+-PWD := $(shell pwd)
++KERNELRELEASE ?= $(shell uname -r)
++KDIR ?= /lib/modules/$(KERNELRELEASE)/build
++PWD ?= $(shell pwd)
+
+-all:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD)
++ccflags-y := -Werror
+
+-clean:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
++default: modules
++install: modules_install
++
++modules modules_install clean:
++ $(MAKE) -C $(KDIR) M=$(PWD) $@