summarylogtreecommitdiffstats
path: root/drawpile.install
diff options
context:
space:
mode:
Diffstat (limited to 'drawpile.install')
-rw-r--r--drawpile.install29
1 files changed, 25 insertions, 4 deletions
diff --git a/drawpile.install b/drawpile.install
index b8c7ebf27b7e..ace6a9c3f0df 100644
--- a/drawpile.install
+++ b/drawpile.install
@@ -1,11 +1,32 @@
-post_install() {
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+
+_update() {
+ msg_blue 'Updating desktop MIME database...'
update-desktop-database -q
}
+post_install() {
+ _update
+ note "If installing optional dependencies afterwards you may have to recompile this package."
+ #note "If you wish to only install the server or client set 'BUILD' to 'SERVER' or 'CLIENT' in the PKGBUILD file and recompile this package."
+}
+
post_upgrade() {
- post_install
+ _update
}
post_remove() {
- post_install
-}
+ _update
+} \ No newline at end of file