summarylogtreecommitdiffstats
path: root/dssi-vst-winexec.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dssi-vst-winexec.patch')
-rw-r--r--dssi-vst-winexec.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dssi-vst-winexec.patch b/dssi-vst-winexec.patch
new file mode 100644
index 000000000000..2681e0ba9ae6
--- /dev/null
+++ b/dssi-vst-winexec.patch
@@ -0,0 +1,23 @@
+Thanks to Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>
+Reviewed by speps <speps at aur dot archlinux dot org>
+
+diff -aur dssi-vst-0.9.2/Makefile dssi-vst-0.9.2.patched/Makefile
+--- dssi-vst-0.9.2/Makefile 2010-05-04 11:01:29.000000000 +0200
++++ dssi-vst-0.9.2.patched/Makefile 2014-03-28 18:24:41.128287015 +0100
+@@ -38,12 +38,15 @@
+ all: $(TARGETS)
+
+ install: all
++ mkdir -p $(DSSIDIR)
+ mkdir -p $(DSSIDIR)/dssi-vst
+ mkdir -p $(LADSPADIR)
+ mkdir -p $(BINDIR)
+ install dssi-vst.so $(DSSIDIR)
+ install dssi-vst.so $(LADSPADIR)
+- install dssi-vst-server.exe.so dssi-vst-server dssi-vst-scanner.exe.so dssi-vst-scanner dssi-vst_gui $(DSSIDIR)/dssi-vst
++ install dssi-vst-server.exe.so dssi-vst-scanner.exe.so dssi-vst_gui $(DSSIDIR)/dssi-vst
++ install dssi-vst-server.exe $(DSSIDIR)/dssi-vst/dssi-vst-server
++ install dssi-vst-scanner.exe $(DSSIDIR)/dssi-vst/dssi-vst-scanner
+ install vsthost $(BINDIR)
+
+ clean: