aboutsummarylogtreecommitdiffstats
path: root/embree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'embree.patch')
-rw-r--r--embree.patch66
1 files changed, 40 insertions, 26 deletions
diff --git a/embree.patch b/embree.patch
index 8f3868f89c70..9fe60af14487 100644
--- a/embree.patch
+++ b/embree.patch
@@ -1,34 +1,31 @@
-diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
-index d9a2ebf8571..f3b7d156024 100644
---- a/intern/cycles/blender/CMakeLists.txt
-+++ b/intern/cycles/blender/CMakeLists.txt
-@@ -66,6 +66,12 @@ if(WITH_CYCLES_LOGGING)
- )
- endif()
-
-+if(WITH_CYCLES_EMBREE)
-+ list(APPEND LIB
-+ ${EMBREE_LIBRARIES}
-+ )
-+endif()
-+
- set(ADDON_FILES
- addon/__init__.py
- addon/engine.py
diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
-index d9d525d4586..03b509a28f3 100644
+index 90cf23d3e13..f625efaa542 100644
--- a/build_files/cmake/Modules/FindEmbree.cmake
+++ b/build_files/cmake/Modules/FindEmbree.cmake
-@@ -72,7 +72,7 @@ ENDFOREACH()
+@@ -7,6 +7,9 @@
+ # EMBREE_ROOT_DIR, The base directory to search for Embree.
+ # This can also be an environment variable.
+ # EMBREEFOUND, If false, do not try to use Embree.
++#
++# also defined, but not for general use are
++# EMBREE_LIBRARY, where to find the Embree library.
+
+ #=============================================================================
+ # Copyright 2018 Blender Foundation.
+@@ -67,14 +70,23 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
+ ENDFOREACH()
+
- FIND_LIBRARY(EMBREE_LIBRARY
- NAMES
-- libembree3
++FIND_LIBRARY(EMBREE_LIBRARY
++ NAMES
+ embree3
- HINTS
- ${_embree_SEARCH_DIRS}
- PATH_SUFFIXES
-@@ -83,10 +83,10 @@ FIND_LIBRARY(EMBREE_LIBRARY
++ HINTS
++ ${_embree_SEARCH_DIRS}
++ PATH_SUFFIXES
++ lib64 lib
++)
++
+ # handle the QUIETLY and REQUIRED arguments and set EMBREE_FOUND to TRUE if
# all listed variables are TRUE
INCLUDE(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(Embree DEFAULT_MSG
@@ -41,3 +38,20 @@ index d9d525d4586..03b509a28f3 100644
SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
ENDIF(EMBREE_FOUND)
+diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
+index 2316800e21e..591841152e2 100644
+--- a/intern/cycles/blender/CMakeLists.txt
++++ b/intern/cycles/blender/CMakeLists.txt
+@@ -67,6 +67,12 @@ if(WITH_CYCLES_LOGGING)
+ )
+ endif()
+
++if(WITH_CYCLES_EMBREE)
++ list(APPEND LIB
++ ${EMBREE_LIBRARIES}
++ )
++endif()
++
+ set(ADDON_FILES
+ addon/__init__.py
+ addon/engine.py