summarylogtreecommitdiffstats
path: root/embree.patch
diff options
context:
space:
mode:
Diffstat (limited to 'embree.patch')
-rw-r--r--embree.patch11
1 files changed, 6 insertions, 5 deletions
diff --git a/embree.patch b/embree.patch
index 4790c4ea873a..e6cee1fb8a62 100644
--- a/embree.patch
+++ b/embree.patch
@@ -1,8 +1,8 @@
diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
-index 90cf23d3e13..f625efaa542 100644
+index bb65a24c4b5..5d1ba7b459a 100644
--- a/build_files/cmake/Modules/FindEmbree.cmake
+++ b/build_files/cmake/Modules/FindEmbree.cmake
-@@ -7,6 +7,9 @@
+@@ -10,6 +10,9 @@
# EMBREE_ROOT_DIR, The base directory to search for Embree.
# This can also be an environment variable.
# EMBREEFOUND, If false, do not try to use Embree.
@@ -10,9 +10,9 @@ index 90cf23d3e13..f625efaa542 100644
+# also defined, but not for general use are
+# EMBREE_LIBRARY, where to find the Embree library.
- #=============================================================================
- # Copyright 2018 Blender Foundation.
-@@ -67,14 +70,23 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
+ # If EMBREE_ROOT_DIR was defined in the environment, use it.
+ IF(NOT EMBREE_ROOT_DIR AND NOT $ENV{EMBREE_ROOT_DIR} STREQUAL "")
+@@ -72,15 +75,24 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
ENDFOREACH()
@@ -38,6 +38,7 @@ index 90cf23d3e13..f625efaa542 100644
SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
ENDIF()
+ MARK_AS_ADVANCED(
diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
index 2316800e21e..591841152e2 100644
--- a/intern/cycles/blender/CMakeLists.txt