summarylogtreecommitdiffstats
path: root/enable_local_build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'enable_local_build.patch')
-rw-r--r--enable_local_build.patch22
1 files changed, 15 insertions, 7 deletions
diff --git a/enable_local_build.patch b/enable_local_build.patch
index 4f8c1c33daba..ae48ebcb53fa 100644
--- a/enable_local_build.patch
+++ b/enable_local_build.patch
@@ -1,14 +1,22 @@
-diff -aur vale-0.4.0-old/Makefile vale-0.4.0-new/Makefile
---- vale-0.4.0-old/Makefile 2017-04-02 20:07:57.000000000 +0200
-+++ vale-0.4.0-new/Makefile 2017-04-08 00:24:11.679719710 +0200
-@@ -76,7 +76,9 @@
+diff -aur vale-0.7.0-old/Makefile vale-0.7.0-new/Makefile
+--- vale-0.7.0-old/Makefile 2017-05-28 22:56:00.000000000 +0200
++++ vale-0.7.0-new/Makefile 2017-05-30 23:00:52.459912244 +0200
+@@ -5,6 +5,7 @@
+ CURR_SHA=$(shell git rev-parse --verify HEAD)
+
+ LDFLAGS=-ldflags "-s -w -X main.version=$(LAST_TAG)"
++RUBY_CUSTOM_PATH=/home/${USER}/.gem/ruby/$(shell ruby -e 'puts RUBY_VERSION')/bin
+
+ .PHONY: clean test lint ci cross install bump rules setup bench compare release
+
+@@ -66,7 +67,9 @@
+ go get -u github.com/alecthomas/gometalinter
go get -u github.com/jteeuwen/go-bindata/...
- go-bindata -ignore=\\.DS_Store -pkg="rule" -o rule/rule.go rule/
gometalinter --install
- bundle install
+ gem install bundle
-+ bundle install --path /home/gizdov/.gem/ruby/2.4.0/bin
++ bundle install --path ${RUBY_CUSTOM_PATH}
+ gem install specific_install
gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
- bump:
+ rules: