summarylogtreecommitdiffstats
path: root/enable_local_build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'enable_local_build.patch')
-rw-r--r--enable_local_build.patch18
1 files changed, 10 insertions, 8 deletions
diff --git a/enable_local_build.patch b/enable_local_build.patch
index ae48ebcb53fa..9a1751191516 100644
--- a/enable_local_build.patch
+++ b/enable_local_build.patch
@@ -1,22 +1,24 @@
-diff -aur vale-0.7.0-old/Makefile vale-0.7.0-new/Makefile
---- vale-0.7.0-old/Makefile 2017-05-28 22:56:00.000000000 +0200
-+++ vale-0.7.0-new/Makefile 2017-05-30 23:00:52.459912244 +0200
+diff -aur vale-0.10.1-old/Makefile vale-0.10.1-new/Makefile
+--- vale-0.10.1-old/Makefile 2018-02-17 04:00:48.000000000 +0100
++++ vale-0.10.1-new/Makefile 2018-03-02 00:01:30.630943963 +0100
@@ -5,6 +5,7 @@
CURR_SHA=$(shell git rev-parse --verify HEAD)
LDFLAGS=-ldflags "-s -w -X main.version=$(LAST_TAG)"
+RUBY_CUSTOM_PATH=/home/${USER}/.gem/ruby/$(shell ruby -e 'puts RUBY_VERSION')/bin
- .PHONY: clean test lint ci cross install bump rules setup bench compare release
+ .PHONY: data test lint ci cross install bump rules setup bench compare release
-@@ -66,7 +67,9 @@
+@@ -66,8 +67,10 @@
go get -u github.com/alecthomas/gometalinter
go get -u github.com/jteeuwen/go-bindata/...
gometalinter --install
- bundle install
-+ gem install bundle
+- gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
++ gem install --no-rdoc --no-ri bundle
+ bundle install --path ${RUBY_CUSTOM_PATH}
-+ gem install specific_install
- gem specific_install -l https://github.com/jdkato/aruba.git -b d-win-fix
++ gem install --no-rdoc --no-ri specific_install
++ gem specific_install -l https://github.com/jdkato/aruba.git
rules:
+ go-bindata -ignore=\\.DS_Store -pkg="rule" -o rule/rule.go rule/*.yml