summarylogtreecommitdiffstats
path: root/expose-cargs-and-largs-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'expose-cargs-and-largs-makefile.patch')
-rw-r--r--expose-cargs-and-largs-makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
new file mode 100644
index 000000000000..113a29a9bd7b
--- /dev/null
+++ b/expose-cargs-and-largs-makefile.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index b591cb9a..4d711028 100644
+--- a/Makefile
++++ b/Makefile
+@@ -67,6 +67,14 @@ else
+ LIBGPR_TYPES=static
+ endif
+
++ifneq ($(strip $(CFLAGS)),)
++ CARGS := -cargs $(CFLAGS)
++endif
++
++ifneq ($(strip $(LDFLAGS)),)
++ LARGS := -largs $(LDFLAGS)
++endif
++
+ # Used to pass extra options to GPRBUILD, like -d for instance
+ GPRBUILD_OPTIONS=
+
+@@ -75,7 +83,7 @@ LIB_INSTALLER=gprinstall -p -f --target=$(TARGET) $(RBD) --prefix=${prefix}
+ CLEANER=gprclean -q $(RBD)
+
+ GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
+- -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable
++ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable $(CARGS) $(LARGS)
+ LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
+ LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
+ --install-name=gpr --build-var=LIBRARY_TYPE $(GTARGET)