summarylogtreecommitdiffstats
path: root/fix-issue-1034.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix-issue-1034.patch')
-rw-r--r--fix-issue-1034.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/fix-issue-1034.patch b/fix-issue-1034.patch
deleted file mode 100644
index 68046eb134ad..000000000000
--- a/fix-issue-1034.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c988508c..ad2c5589 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -128,7 +128,7 @@ find_package(pugixml REQUIRED)
- find_package(RapidJSON REQUIRED)
- find_package(Boost COMPONENTS program_options filesystem nowide REQUIRED)
- find_package(libzip REQUIRED)
--find_package(glslang REQUIRED)
-+find_package(Vulkan COMPONENTS glslang REQUIRED)
- find_package(ZLIB REQUIRED)
- find_package(zstd MODULE REQUIRED) # MODULE so that zstd::zstd is available
- find_package(OpenSSL COMPONENTS Crypto SSL REQUIRED)
-@@ -136,11 +136,6 @@ find_package(glm REQUIRED)
- find_package(fmt 9 REQUIRED)
- find_package(PNG REQUIRED)
-
--# glslang versions older than 11.11.0 define targets without a namespace
--if (NOT TARGET glslang::SPIRV AND TARGET SPIRV)
-- add_library(glslang::SPIRV ALIAS SPIRV)
--endif()
--
- if (UNIX AND NOT APPLE)
- find_package(X11 REQUIRED)
- if (ENABLE_WAYLAND)
-diff --git a/src/Cafe/CMakeLists.txt b/src/Cafe/CMakeLists.txt
-index 29c5a0b3..4d0e8def 100644
---- a/src/Cafe/CMakeLists.txt
-+++ b/src/Cafe/CMakeLists.txt
-@@ -516,7 +516,7 @@ target_link_libraries(CemuCafe PRIVATE
- Boost::nowide
- CURL::libcurl
- fmt::fmt
-- glslang::SPIRV
-+ Vulkan::glslang
- ih264d
- OpenSSL::Crypto
- OpenSSL::SSL