summarylogtreecommitdiffstats
path: root/fix-lib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix-lib.patch')
-rw-r--r--fix-lib.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/fix-lib.patch b/fix-lib.patch
new file mode 100644
index 000000000000..e90d33d056d2
--- /dev/null
+++ b/fix-lib.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -151,7 +151,7 @@ INITSYS_TYPES = sorted([f.partition(".")[0] for f in INITSYS_ROOTS.keys()])
+ USR = "usr"
+ ETC = "etc"
+ USR_LIB_EXEC = "usr/lib"
+-LIB = "lib"
++LIB = "usr/lib"
+ if os.uname()[0] == 'FreeBSD':
+ USR = "usr/local"
+ USR_LIB_EXEC = "usr/local/lib"