summarylogtreecommitdiffstats
path: root/fix-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix-linking.patch')
-rw-r--r--fix-linking.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/fix-linking.patch b/fix-linking.patch
new file mode 100644
index 000000000000..073c9bb06bf5
--- /dev/null
+++ b/fix-linking.patch
@@ -0,0 +1,15 @@
+diff -urN arrow-apache-arrow-0.11.0-orig/cpp/CMakeLists.txt arrow-apache-arrow-0.11.0/cpp/CMakeLists.txt
+--- arrow-apache-arrow-0.11.0-orig/cpp/CMakeLists.txt 2018-10-11 10:18:19.912126993 -0400
++++ arrow-apache-arrow-0.11.0/cpp/CMakeLists.txt 2018-10-11 10:18:41.159412003 -0400
+@@ -646,8 +646,9 @@
+
+ if (ARROW_ORC)
+ SET(ARROW_STATIC_LINK_LIBS
+- ${ARROW_STATIC_LINK_LIBS}
+- orc)
++ orc ${ARROW_STATIC_LINK_LIBS}
++ )
+ endif()
++ message(STATUS ${ARROW_STATIC_LINK_LIBS})
+
+ if (ARROW_USE_GLOG)