summarylogtreecommitdiffstats
path: root/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix-makefile.patch')
-rw-r--r--fix-makefile.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/fix-makefile.patch b/fix-makefile.patch
new file mode 100644
index 000000000000..af865b9359d5
--- /dev/null
+++ b/fix-makefile.patch
@@ -0,0 +1,54 @@
+diff -Naur z88dk.old/Makefile z88dk/Makefile
+--- z88dk.old/Makefile 2018-09-06 05:00:11.000000000 +0200
++++ z88dk/Makefile 2019-02-09 12:59:16.622305360 +0100
+@@ -25,11 +25,6 @@
+ EXEC_PREFIX ?=
+ CROSS ?= 0
+
+-ifneq (, $(shell which ccache))
+- OCC := $(CC)
+- CC := ccache $(CC)
+-endif
+-
+ SDCC_PATH = /tmp/sdcc
+ Z88DK_PATH = $(shell pwd)
+
+@@ -38,7 +33,7 @@
+ export CC INSTALL CFLAGS EXEC_PREFIX CROSS
+
+ all: setup appmake copt zcpp ucpp sccz80 z80asm zcc zpragma zx7 z80nm zobjcopy \
+- lstmanip ticks z80svg font2pv1000 testsuite z88dk-lib zsdcc
++ lstmanip ticks z80svg font2pv1000 testsuite z88dk-lib
+
+ setup:
+ $(shell if [ "${git_count}" != "" ]; then \
+@@ -64,9 +59,9 @@
+ --disable-avr-port --disable-ds390-port \
+ --disable-ds400-port --disable-hc08-port \
+ --disable-pic-port --disable-pic14-port \
+- --disable-pic16-port --disable-stm8-port \
++ --disable-pic16-port --disable-stm8-port \
+ --disable-tlcs90-port --disable-s08-port \
+- --disable-ucsim --disable-device-lib \
++ --disable-ucsim --disable-device-lib \
+ --disable-packihx
+ cd $(SDCC_PATH) && $(MAKE)
+ cd $(SDCC_PATH) && mv ./bin/sdcc $(Z88DK_PATH)/bin/zsdcc
+@@ -143,7 +138,7 @@
+ cd libsrc ; $(MAKE) install
+
+ install: install-clean
+- install -d $(DESTDIR)/$(prefix) $(DESTDIR)/$(prefix_share)/lib
++ install -d $(DESTDIR)/$(prefix) $(DESTDIR)/$(prefix)/bin $(DESTDIR)/$(prefix_share)/lib
+ $(MAKE) -C src/appmake PREFIX=$(DESTDIR)/$(prefix) install
+ $(MAKE) -C src/copt PREFIX=$(DESTDIR)/$(prefix) install
+ $(MAKE) -C src/ucpp PREFIX=$(DESTDIR)/$(prefix) install
+@@ -204,6 +199,7 @@
+ $(MAKE) -C test clean
+ $(MAKE) -C testsuite clean
+ $(MAKE) -C src/z88dk-lib clean
+- #if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
++# if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
+
+ .PHONY: test testsuite
++