summarylogtreecommitdiffstats
path: root/fix-whitespace-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix-whitespace-Makefile.patch')
-rw-r--r--fix-whitespace-Makefile.patch27
1 files changed, 11 insertions, 16 deletions
diff --git a/fix-whitespace-Makefile.patch b/fix-whitespace-Makefile.patch
index c857e3e0b22e..6dca8f4fd261 100644
--- a/fix-whitespace-Makefile.patch
+++ b/fix-whitespace-Makefile.patch
@@ -1,14 +1,14 @@
---- Makefile 2021-02-14 12:59:55.868073893 +0100
-+++ Makefile 2021-02-14 13:02:54.451661445 +0100
+--- Makefile.orig 2022-07-27 21:48:59.652388484 +0200
++++ Makefile 2022-07-27 21:49:30.261649271 +0200
@@ -53,7 +53,7 @@
bin/z88dk-ticks$(EXESUFFIX) bin/z88dk-z80svg$(EXESUFFIX) \
bin/z88dk-font2pv1000$(EXESUFFIX) bin/z88dk-basck$(EXESUFFIX) \
- bin/z88dk-lib$(EXESUFFIX)
+ bin/z88dk-lib$(EXESUFFIX) bin/z88dk-zx0$(EXESUFFIX)
-
+
ALL = $(BINS) testsuite
- ALL_EXT = bin/zsdcc$(EXESUFFIX)
+ ALL_EXT = bin/z88dk-zsdcc$(EXESUFFIX)
@@ -81,7 +81,7 @@
tar xzf $^
touch $@
@@ -18,18 +18,17 @@
patch -d $(SDCC_PATH) -p0 < $(Z88DK_PATH)/src/zsdcc/sdcc-z88dk.patch
endif
endif
-@@ -93,7 +93,7 @@
+@@ -93,7 +93,6 @@
zsdcc-tarball: $(SDCC_PATH)/configure
@mkdir -p dist
tar --exclude=.svn -cvzf dist/zsdcc_r$(SDCC_VERSION)_src.tar.gz src/sdcc-build
-
-+
$(SDCC_PATH)/Makefile: $(SDCC_PATH)/configure
ifdef BUILD_SDCC
-@@ -200,17 +200,17 @@
- cp -r src/m4 $(prefix_share)/src/
-
+@@ -209,13 +208,13 @@
+ $(MAKE) -C libsrc install-clean
+ $(RM) lib/z80asm*.lib
- # BSD install syntax below
- #find include -type d -exec $(INSTALL) -d -m 755 {,$(prefix_share)/}{} \;
@@ -48,16 +47,12 @@
# Needs to have a dependency on libs
--test: $(ALL)
-+test: $(ALL)
- $(MAKE) -C test
-
- testsuite: $(BINS)
-@@ -251,6 +251,6 @@
+@@ -259,7 +258,7 @@
$(RM) $(SDCC_DEPS)
endif
endif
- #if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
+#if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
- .PHONY: test testsuite
+ test-clean:
+ $(MAKE) -C test clean