summarylogtreecommitdiffstats
path: root/fix_xdg_dep_on_arch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fix_xdg_dep_on_arch.patch')
-rw-r--r--fix_xdg_dep_on_arch.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/fix_xdg_dep_on_arch.patch b/fix_xdg_dep_on_arch.patch
new file mode 100644
index 000000000000..3207d2af1070
--- /dev/null
+++ b/fix_xdg_dep_on_arch.patch
@@ -0,0 +1,27 @@
+diff --git i/setup.py w/setup.py
+index 3306e73..b9b32e6 100644
+--- i/setup.py
++++ w/setup.py
+@@ -33,7 +33,7 @@ setup(
+ 'urwid>=1.3.0',
+ 'urwidtrees>=1.0.3dev0',
+ 'aiohttp>=0.22.5',
+- 'xdg',
++ 'pyxdg',
+ 'blinker',
+ 'natsort',
+ ],
+diff --git i/stig/settings/defaults.py w/stig/settings/defaults.py
+index 59a51eb..f35d6fc 100644
+--- i/stig/settings/defaults.py
++++ w/stig/settings/defaults.py
+@@ -13,7 +13,8 @@ from ..logging import make_logger
+ log = make_logger(__name__)
+
+ import os
+-from xdg import (XDG_CONFIG_HOME, XDG_CACHE_HOME)
++from xdg.BaseDirectory import xdg_config_home as XDG_CONFIG_HOME
++from xdg.BaseDirectory import xdg_cache_home as XDG_CACHE_HOME
+
+ from .. import APPNAME
+ from ..views.torrentlist import COLUMNS as TORRENT_COLUMNS