summarylogtreecommitdiffstats
path: root/fixerrors.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fixerrors.patch')
-rw-r--r--fixerrors.patch62
1 files changed, 53 insertions, 9 deletions
diff --git a/fixerrors.patch b/fixerrors.patch
index 952046104b6f..0c87c4b4fed2 100644
--- a/fixerrors.patch
+++ b/fixerrors.patch
@@ -1,16 +1,60 @@
-Fix errors in Makefile.in
-Actually I cannot understand why this could happen.
-
---- nvi-1.79.old/build/Makefile.in 1996-10-23 22:43:38.000000000 +0900
-+++ nvi-1.79.new/build/Makefile.in 2015-09-05 23:55:22.340436768 +0900
-@@ -139,8 +139,8 @@
- cd $(datadir)/vi/catalog && $(chmod) $(fmode) *)
+--- a/build/Makefile.in
++++ b/build/Makefile.in
+@@ -4,7 +4,7 @@ srcdir= @srcdir@/..
+ CC= @CC@
+ OPTFLAG=@OPTFLAG@
+ CFLAGS= -c $(OPTFLAG) @CFLAGS@ -I. -I$(srcdir)/include @CPPFLAGS@
+-LDFLAGS=@LDFLAGS@
++LDFLAGS=-lreadline -lncurses
+ PERL= @vi_cv_path_perl@
+ PERLLIB=@vi_cv_perllib@
+ SHRPENV=@shrpenv@
+@@ -139,8 +139,8 @@ install_common:
+ cd $(datadir)/vi/catalog && $(chmod) $(fmode) *)
@echo "Installing Perl scripts: $(datadir)/vi/perl ..."
$(mkdir) $(datadir)/vi/perl && $(chmod) $(dmode) $(datadir)/vi/perl
- [ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
- cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm)
-+ -[ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
-+ cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm
++ #[ -f VI.pm ] && $(cp) VI.pm $(datadir)/vi/perl && \
++ # cd $(datadir)/vi/perl && $(chmod) $(fmode) VI.pm
(cd $(srcdir)/perl_scripts && $(cp) *.pl $(datadir)/vi/perl && \
cd $(datadir)/vi/perl && $(chmod) $(fmode) *.pl)
@echo "Installing Tcl scripts: $(datadir)/vi/tcl ..."
+--- a/ex/ex_script.c
++++ b/ex/ex_script.c
+@@ -23,9 +23,11 @@ static const char sccsid[] = "@(#)ex_script.c 10.30 (Berkeley) 9/24/96";
+ #include <sys/select.h>
+ #endif
+ #include <sys/stat.h>
++
+ #ifdef HAVE_SYS5_PTY
+-#include <sys/stropts.h>
++ //#include <sys/stropts.h>
+ #endif
++
+ #include <sys/time.h>
+ #include <sys/wait.h>
+
+@@ -718,19 +720,19 @@ ptys_open(fdm, pts_name)
+ return (-5);
+ }
+
+- if (ioctl(fds, I_PUSH, "ptem") < 0) {
++ if (ioctl(fds, TIOCPKT, "ptem") < 0) {
+ close(fds);
+ close(fdm);
+ return (-6);
+ }
+
+- if (ioctl(fds, I_PUSH, "ldterm") < 0) {
++ if (ioctl(fds, TIOCPKT, "ldterm") < 0) {
+ close(fds);
+ close(fdm);
+ return (-7);
+ }
+
+- if (ioctl(fds, I_PUSH, "ttcompat") < 0) {
++ if (ioctl(fds, TIOCPKT, "ttcompat") < 0) {
+ close(fds);
+ close(fdm);
+ return (-8);