summarylogtreecommitdiffstats
path: root/fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fixes.patch')
-rw-r--r--fixes.patch47
1 files changed, 20 insertions, 27 deletions
diff --git a/fixes.patch b/fixes.patch
index a34f63a13cea..b31508fb9012 100644
--- a/fixes.patch
+++ b/fixes.patch
@@ -1,36 +1,29 @@
---- po4a/Makefile 2013-09-17 11:58:14.177059023 +0100
-+++ po4a/Makefile 2013-09-17 11:57:31.943725986 +0100
-@@ -25,7 +25,7 @@
- pod2man --utf8 --center=" " --release="Debian-Hilfswerkzeuge" $< > $@
- de/%.de.1: de/%.de.dbk translate
- xsltproc --nonet -o $@ \
-- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
- # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
- # to rename the file after it's generated
- mv de/$*.1 $@
-@@ -35,7 +35,7 @@
- pod2man --utf8 --center=" " --release="Utilitaires Debian" $< > $@
- fr/%.fr.1: fr/%.fr.dbk translate
- xsltproc --nonet -o $@ \
+diff -urN devscripts-2.21.2/po4a/Makefile devscripts-2.21.2_patched/po4a/Makefile
+--- devscripts-2.21.2/po4a/Makefile 2021-03-16 14:16:39.000000000 +0100
++++ devscripts-2.21.2_patched/po4a/Makefile 2021-06-10 12:31:21.021880200 +0200
+@@ -34,7 +34,7 @@
+ pod2man --utf8 --center=" " --release="$(DESC_$(dir $@))" $< > $@
+ %.1:: %.dbk translate
+ xsltproc --nonet \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
- # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
- # to rename the file after it's generated
- mv fr/$*.1 $@
---- scripts/Makefile 2011-02-09 08:39:18.000000000 +0100
-+++ scripts/Makefile 2011-02-13 17:50:50.393333338 +0100
-@@ -61,7 +61,7 @@
++ /usr/share/xml/docbook/xsl-stylesheets-$(shell pacman -Q docbook-xsl | sed -E 's|.* ([0-9.]+)-.*|\1|')/manpages/docbook.xsl $<
+ # /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/other.xsl
+ # (which is imported by the above stylesheet) insists in writing the output
+ # to where it wants to. we can only move the file ourselves.
+diff -urN devscripts-2.21.2/scripts/Makefile devscripts-2.21.2_patched/scripts/Makefile
+--- devscripts-2.21.2/scripts/Makefile 2021-03-16 14:16:39.000000000 +0100
++++ devscripts-2.21.2_patched/scripts/Makefile 2021-06-10 12:35:12.481880200 +0200
+@@ -87,7 +87,7 @@
pod2man --utf8 --center=" " --release="Debian Utilities" $< > $@
%.1: %.dbk
xsltproc --nonet -o $@ \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-$(shell pacman -Q docbook-xsl | sed -E 's|.* ([0-9.]+)-.*|\1|')/manpages/docbook.xsl $<
- # There is a slight chance this gets called twice, once here from here and once
- # from ../po4a/Makefile. Treat files with care.
-@@ -89,7 +89,7 @@
- $(foreach python,$(shell py3versions -r ../debian/control),$(python) setup.py test$(\n))
+ # Syntax checker
+ test_sh: $(SH_CHECKS)
+@@ -142,7 +142,7 @@
+ test: test_pl test_sh test_py
install: all
- python3 setup.py install --root="$(DESTDIR)" --no-compile --install-layout=deb