summarylogtreecommitdiffstats
path: root/force_qt5.patch
diff options
context:
space:
mode:
Diffstat (limited to 'force_qt5.patch')
-rw-r--r--force_qt5.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/force_qt5.patch b/force_qt5.patch
index babf63bebfca..17b8f9fd155a 100644
--- a/force_qt5.patch
+++ b/force_qt5.patch
@@ -1,12 +1,12 @@
diff -rupN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-06-14 12:18:25.506502296 -0700
-+++ b/CMakeLists.txt 2022-06-14 12:18:38.946502190 -0700
+--- a/CMakeLists.txt 2023-05-26 14:14:14.718672640 -0700
++++ b/CMakeLists.txt 2023-05-26 14:14:26.132005819 -0700
@@ -22,7 +22,7 @@ set(CMAKE_CXX_STANDARD 11)
include(FeatureSummary)
-find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
+find_package(QT NAMES Qt5 REQUIRED COMPONENTS Core)
- find_package(Qt${QT_VERSION_MAJOR} 5.6 REQUIRED COMPONENTS
+ find_package(Qt${QT_VERSION_MAJOR} 5.10 REQUIRED COMPONENTS
Core Widgets PrintSupport Network)
- if(QT_VERSION_MAJOR GREATER 5)
+ if(Qt5_FOUND AND NOT TARGET Qt::Core)