summarylogtreecommitdiffstats
path: root/g15mpd-libmpdheader.patch
diff options
context:
space:
mode:
Diffstat (limited to 'g15mpd-libmpdheader.patch')
-rw-r--r--g15mpd-libmpdheader.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/g15mpd-libmpdheader.patch b/g15mpd-libmpdheader.patch
new file mode 100644
index 000000000000..d406e0695f5b
--- /dev/null
+++ b/g15mpd-libmpdheader.patch
@@ -0,0 +1,27 @@
+--- g15mpd-1.0.0.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ g15mpd-1.0.0/autogen.sh 2009-07-16 20:20:36.067515353 +0200
+@@ -0,0 +1,2 @@
++#!/bin/sh
++autoreconf -vfi
+--- g15mpd-1.0.0.orig/configure.in 2007-02-11 02:33:42.000000000 +0100
++++ g15mpd-1.0.0/configure.in 2009-07-16 20:18:18.628616415 +0200
+@@ -18,7 +18,7 @@ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(g15daemon_client.h libg15render.h,,AC_MSG_ERROR(["libg15daemon_client (or its devel package) could not be found. please install it"]))
+ AC_CHECK_HEADERS(X11/Xlib.h X11/XF86keysym.h,,AC_MSG_ERROR(["Xorg development files could not be found. please install the devel package"]))
+ AC_CHECK_HEADERS(X11/extensions/XTest.h,,AC_MSG_ERROR(["Xorg XTEST Extension devel headers could not be found. please install the devel package"]))
+-AC_CHECK_HEADERS(libmpd/libmpd.h,,AC_MSG_ERROR(["libmpd development files could not be found. please install the libmpd devel package"]))
++AC_CHECK_HEADERS(libmpd-1.0/libmpd/libmpd.h,,AC_MSG_ERROR(["libmpd development files could not be found. please install the libmpd devel package"]))
+ AC_PATH_X
+
+ AC_OUTPUT(Makefile)
+--- g15mpd-1.0.0.orig/g15mpd.c 2007-01-01 21:51:41.000000000 +0100
++++ g15mpd-1.0.0/g15mpd.c 2009-07-16 20:30:02.213366872 +0200
+@@ -26,7 +26,7 @@
+ This is a simple frontend for the Media Player Daemon (MPD)
+ */
+
+-#include <libmpd/libmpd.h>
++#include <libmpd-1.0/libmpd/libmpd.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>