summarylogtreecommitdiffstats
path: root/gcc-4.7-no-exceptions.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.7-no-exceptions.patch')
-rwxr-xr-xgcc-4.7-no-exceptions.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gcc-4.7-no-exceptions.patch b/gcc-4.7-no-exceptions.patch
new file mode 100755
index 000000000000..f6ddd041c11b
--- /dev/null
+++ b/gcc-4.7-no-exceptions.patch
@@ -0,0 +1,28 @@
+--- libgcc/Makefile.in.orig 2013-06-01 23:11:45.068778210 +0200
++++ libgcc/Makefile.in 2013-06-01 23:14:55.835165466 +0200
+@@ -500,14 +500,14 @@
+ lib2-divmod-o = $(patsubst %,%$(objext),$(LIB2_DIVMOD_FUNCS))
+ $(lib2-divmod-o): %$(objext): $(srcdir)/libgcc2.c
+ $(gcc_compile) -DL$* -c $< \
+- -fexceptions -fnon-call-exceptions $(vis_hide)
++ -fno-exceptions -fnon-call-exceptions $(vis_hide)
+ libgcc-objects += $(lib2-divmod-o)
+
+ ifeq ($(enable_shared),yes)
+ lib2-divmod-s-o = $(patsubst %,%_s$(objext),$(LIB2_DIVMOD_FUNCS))
+ $(lib2-divmod-s-o): %_s$(objext): $(srcdir)/libgcc2.c
+ $(gcc_s_compile) -DL$* -c $< \
+- -fexceptions -fnon-call-exceptions
++ -fno-exceptions -fnon-call-exceptions
+ libgcc-s-objects += $(lib2-divmod-s-o)
+ endif
+
+@@ -814,7 +814,7 @@
+ # libgcc_eh.a, only LIB2ADDEH matters. If we do, only LIB2ADDEHSTATIC and
+ # LIB2ADDEHSHARED matter. (Usually all three are identical.)
+
+-c_flags := -fexceptions
++c_flags := -fno-exceptions
+
+ ifeq ($(enable_shared),yes)
+