summarylogtreecommitdiffstats
path: root/gcc-4.9-no-exceptions.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.9-no-exceptions.patch')
-rw-r--r--gcc-4.9-no-exceptions.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gcc-4.9-no-exceptions.patch b/gcc-4.9-no-exceptions.patch
new file mode 100644
index 000000000000..8cf36f718133
--- /dev/null
+++ b/gcc-4.9-no-exceptions.patch
@@ -0,0 +1,20 @@
+--- libgcc/Makefile.in.orig 2013-06-01 23:57:51.711127513 +0200
++++ libgcc/Makefile.in 2013-06-01 23:59:13.940660435 +0200
+@@ -492,7 +492,7 @@
+ ifeq ($(LIB2_DIVMOD_EXCEPTION_FLAGS),)
+ # Provide default flags for compiling divmod functions, if they haven't been
+ # set already by a target-specific Makefile fragment.
+-LIB2_DIVMOD_EXCEPTION_FLAGS := -fexceptions -fnon-call-exceptions
++LIB2_DIVMOD_EXCEPTION_FLAGS := -fno-exceptions -fnon-call-exceptions
+ endif
+
+ # Build LIB2_DIVMOD_FUNCS.
+@@ -813,7 +813,7 @@
+ # libgcc_eh.a, only LIB2ADDEH matters. If we do, only LIB2ADDEHSTATIC and
+ # LIB2ADDEHSHARED matter. (Usually all three are identical.)
+
+-c_flags := -fexceptions
++c_flags := -fno-exceptions
+
+ ifeq ($(enable_shared),yes)
+