summarylogtreecommitdiffstats
path: root/gdal-perl-vendor.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gdal-perl-vendor.patch')
-rw-r--r--gdal-perl-vendor.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gdal-perl-vendor.patch b/gdal-perl-vendor.patch
new file mode 100644
index 000000000000..a0bc27d10ca8
--- /dev/null
+++ b/gdal-perl-vendor.patch
@@ -0,0 +1,28 @@
+Description: pass INSTALLDIRS=vendor to Makefile.PL to get stuff into the right place
+Origin: vendor
+Forwarded: not-needed
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2014-07-08
+
+--- a/swig/perl/Makefile
++++ b/swig/perl/Makefile
+@@ -7,7 +7,7 @@ build: Makefile_Geo__GDAL
+ $(MAKE) -f Makefile_Geo__OSR
+
+ Makefile_Geo__GDAL:
+- perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
++ perl Makefile.PL INSTALLDIRS=vendor
+
+ test: build
+ $(MAKE) -f Makefile_Geo__GDAL test
+--- a/swig/perl/GNUmakefile
++++ b/swig/perl/GNUmakefile
+@@ -30,7 +30,7 @@ build: gdal_wrap.cc Makefile_Geo__GDAL
+ gdal_wrap.cc: generate
+
+ Makefile_Geo__GDAL:
+- perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
++ perl Makefile.PL INSTALLDIRS=vendor
+
+ test: build
+ $(MAKE) -f Makefile_Geo__GDAL test