summarylogtreecommitdiffstats
path: root/generate_patches
diff options
context:
space:
mode:
Diffstat (limited to 'generate_patches')
-rwxr-xr-xgenerate_patches10
1 files changed, 9 insertions, 1 deletions
diff --git a/generate_patches b/generate_patches
index 3288fcb55727..2a64a44fd62d 100755
--- a/generate_patches
+++ b/generate_patches
@@ -6,7 +6,15 @@ makepkg -o --nodeps --noprepare --skipinteg
pushd src/${_pkgbase}-${pkgver}
-sed '/APACHE_THREADED_MPM=/d' -i.orig sapi/apache2handler/config.m4 -i.orig configure
+sed '/APACHE_THREADED_MPM=/d' -i.orig sapi/apache2handler/config.m4
+
+sed \
+ -e '/APACHE_THREADED_MPM=/d' \
+ -e '/elif test -f $i\/include\/enchant.h; then/i\\t\telif test -f $i/include/enchant-2/enchant.h; then\n\t\t\tENCHANT_DIR=$i\n\t\t\tENCHANT_INCDIR=$i/include/enchant-2' \
+ -e '/for i in $PHP_FREETYPE_DIR \/usr\/local \/usr; do/a\\n\tif test -d "$i/include/freetype2"; then\n\t\tFREETYPE2_DIR=$i/include/freetype2\n\t\tFREETYPE2_CONFIG="pkg-config freetype2"' \
+ -e '/if test -f "$i\/bin\/freetype-config"; then/, +2d' \
+ -e '/freetype-config not found/c\\t\tas_fn_error $? "freetype2 not found." "$LINENO" 5' \
+ -i.orig configure
sed 's/.conf.default/.conf/g' -i.orig sapi/fpm/Makefile.frag