summarylogtreecommitdiffstats
path: root/generic-desktop-profile.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'generic-desktop-profile.cfg')
-rw-r--r--generic-desktop-profile.cfg35
1 files changed, 35 insertions, 0 deletions
diff --git a/generic-desktop-profile.cfg b/generic-desktop-profile.cfg
new file mode 100644
index 000000000000..ac64d8a016c4
--- /dev/null
+++ b/generic-desktop-profile.cfg
@@ -0,0 +1,35 @@
+# linux-TkG config file
+# Generic Desktop
+
+
+#### KERNEL OPTIONS ####
+
+# Disable some non-module debugging - See PKGBUILD for the list
+_debugdisable="false"
+
+# LEAVE AN EMPTY VALUE TO BE PROMPTED ABOUT FOLLOWING OPTIONS AT BUILD TIME
+
+# Set to "true" to disable FUNCTION_TRACER/GRAPH_TRACER, lowering overhead but limiting debugging and analyzing of kernel functions - Kernel default is "false"
+_ftracedisable="false"
+
+# Set to "true" to disable NUMA, lowering overhead, but breaking CUDA/NvEnc on Nvidia equipped systems - Kernel default is "false"
+_numadisable="false"
+
+# Set to "true" to use explicit preemption points to lower latency at the cost of a small throughput loss - Can give a nice perf boost in VMs - Kernel default is "false"
+_voluntary_preempt="false"
+
+# A selection of patches from Zen/Liquorix kernel and additional tweaks for a better gaming experience (ZENIFY) - Default is "true"
+_zenify="true"
+
+# compiler optimization level - 1. Optimize for performance (-O2); 2. Optimize harder (-O3); 3. Optimize for size (-Os) - Kernel default is "2"
+_compileroptlevel="1"
+
+# Trust the CPU manufacturer to initialize Linux's CRNG (RANDOM_TRUST_CPU) - Kernel default is "false"
+_random_trust_cpu="false"
+
+# CPU scheduler runqueue sharing - No sharing (RQ_NONE), SMT (hyperthread) siblings (RQ_SMT), Multicore siblings (RQ_MC), Symmetric Multi-Processing (RQ_SMP), NUMA (RQ_ALL)
+# Valid values are "none", "smt", "mc", "mc-llc"(for zen), "smp", "all" - Kernel default is "mc"
+_runqueue_sharing="mc"
+
+# Timer frequency - "500", "750" or "1000" - More options available in kernel config prompt when left empty depending on selected cpusched - Kernel default is "750"
+_timer_freq="500"