summarylogtreecommitdiffstats
path: root/get-latest-images-urls.sh
diff options
context:
space:
mode:
Diffstat (limited to 'get-latest-images-urls.sh')
-rwxr-xr-xget-latest-images-urls.sh30
1 files changed, 30 insertions, 0 deletions
diff --git a/get-latest-images-urls.sh b/get-latest-images-urls.sh
new file mode 100755
index 000000000000..d99235b95024
--- /dev/null
+++ b/get-latest-images-urls.sh
@@ -0,0 +1,30 @@
+#!/bin/zsh
+curl 'https://sourceforge.net/projects/waydroid/rss?path=/images' -o file-list.rss
+echo "Latest x86_64 vendor:"
+grep link file-list.rss | grep -- '-waydroid_x86_64-vendor.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo "Latest x86_64 GAPPS:"
+grep link file-list.rss | grep -- '-GAPPS-waydroid_x86_64-system.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo
+
+echo "Latest x86 vendor:"
+grep link file-list.rss | grep -- '-waydroid_x86-vendor.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo "Latest x86 GAPPS:"
+grep link file-list.rss | grep -- '-GAPPS-waydroid_x86-system.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo
+
+echo "Latest arm64 vendor:"
+grep link file-list.rss | grep -- '-waydroid_arm64-vendor.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo "Latest arm64 GAPPS:"
+grep link file-list.rss | grep -- '-GAPPS-waydroid_arm64-system.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo
+
+echo "Latest arm vendor:"
+grep link file-list.rss | grep -- '-waydroid_arm-vendor.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+echo "Latest arm GAPPS:"
+grep link file-list.rss | grep -- '-GAPPS-waydroid_arm-system.zip' | sed 's/<[^>]*>//g' | sed -E 's/\/download//' | sed -E 's/\s+//g' | head -1 | grep --color -E '[0-9]{8}'
+
+#cleanup
+#rm file-list.rss
+
+# perhaps fix in future so we change date in PKGBUILD and then do
+# updpkgsums (util found in pacman-contrib so the checksums is updated)