summarylogtreecommitdiffstats
path: root/getsizes.sh
diff options
context:
space:
mode:
Diffstat (limited to 'getsizes.sh')
-rwxr-xr-xgetsizes.sh10
1 files changed, 5 insertions, 5 deletions
diff --git a/getsizes.sh b/getsizes.sh
index fa4e4e77e926..c149482521b1 100755
--- a/getsizes.sh
+++ b/getsizes.sh
@@ -2,16 +2,16 @@
# Get sizes of ddnet-maps-git package file, and repository and types dirs
# This should be ran only after a successful build
-test -f PKGBUILD || exit 1
-test -d src || exit 1
+test -f PKGBUILD && source PKGBUILD || exit 1
+test -d src/$_name || exit 1
+test -d pkg/$pkgname/usr/share/ddnet/data/types/ || exit 1
-source PKGBUILD
+echo -e "Sizes as of $pkgver :\n"
-echo "Sizes as of $pkgver :"
-echo ""
du -shD $pkgname-$pkgver-$pkgrel-$arch.pkg.tar.xz
du -sh src/$_name | cut -d' ' -f1
echo ""
+
cd pkg/$pkgname
for type in $(ls usr/share/ddnet/data/types/); do
du -sh usr/share/ddnet/data/types/$type