summarylogtreecommitdiffstats
path: root/getsizes.sh
diff options
context:
space:
mode:
Diffstat (limited to 'getsizes.sh')
-rwxr-xr-xgetsizes.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/getsizes.sh b/getsizes.sh
new file mode 100755
index 000000000000..fa4e4e77e926
--- /dev/null
+++ b/getsizes.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+# Get sizes of ddnet-maps-git package file, and repository and types dirs
+# This should be ran only after a successful build
+
+test -f PKGBUILD || exit 1
+test -d src || exit 1
+
+source PKGBUILD
+
+echo "Sizes as of $pkgver :"
+echo ""
+du -shD $pkgname-$pkgver-$pkgrel-$arch.pkg.tar.xz
+du -sh src/$_name | cut -d' ' -f1
+echo ""
+cd pkg/$pkgname
+for type in $(ls usr/share/ddnet/data/types/); do
+ du -sh usr/share/ddnet/data/types/$type
+done
+