summarylogtreecommitdiffstats
path: root/git-3a477f69.patch
diff options
context:
space:
mode:
Diffstat (limited to 'git-3a477f69.patch')
-rw-r--r--git-3a477f69.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/git-3a477f69.patch b/git-3a477f69.patch
new file mode 100644
index 000000000000..fa158271e69a
--- /dev/null
+++ b/git-3a477f69.patch
@@ -0,0 +1,52 @@
+From 3a477f6903c0f901fa3973c1d9b9979f9c3a0cfb Mon Sep 17 00:00:00 2001
+From: Christoph Oelckers <coelckers@zdoom.fake>
+Date: Sun, 23 Jun 2013 20:54:21 +0200
+Subject: [PATCH] - DavidPH's patch for Linux compilation.
+
+---
+ src/CMakeLists.txt | 1 +
+ src/sdl/i_main.cpp | 2 +-
+ src/sdl/i_system.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index a77ee7c..6ba8070 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -682,6 +682,7 @@ add_executable( zdoom WIN32
+ g_skill.cpp
+ gameconfigfile.cpp
+ gi.cpp
++ gitinfo.cpp
+ hu_scores.cpp
+ i_net.cpp
+ info.cpp
+diff --git a/src/sdl/i_main.cpp b/src/sdl/i_main.cpp
+index 48395ce..65b992f 100644
+--- a/src/sdl/i_main.cpp
++++ b/src/sdl/i_main.cpp
+@@ -286,7 +286,7 @@ int main (int argc, char **argv)
+
+ char caption[100];
+ mysnprintf(caption, countof(caption), GAMESIG " %s (%s)", GetVersionString(), GetGitTime());
+- SDL_WM_SetCaption(caption);
++ SDL_WM_SetCaption(caption, caption);
+
+ #ifdef __APPLE__
+
+diff --git a/src/sdl/i_system.cpp b/src/sdl/i_system.cpp
+index cea3cb1..46e3898 100644
+--- a/src/sdl/i_system.cpp
++++ b/src/sdl/i_system.cpp
+@@ -619,7 +619,7 @@ int I_PickIWad (WadStuff *wads, int numwads, bool showwin, int defaultiwad)
+ FString cmd("kdialog --title \""GAMESIG" ");
+ cmd << GetVersionString() << ": Select an IWAD to use\""
+ " --menu \"ZDoom found more than one IWAD\n"
+- "Select from the list below to determine which one to use:\"");
++ "Select from the list below to determine which one to use:\"";
+
+ for(i = 0; i < numwads; ++i)
+ {
+--
+1.8.3.2
+