summarylogtreecommitdiffstats
path: root/gitahead.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gitahead.patch')
-rw-r--r--gitahead.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/gitahead.patch b/gitahead.patch
index c57f8785dc8c..17f62a5bc5f2 100644
--- a/gitahead.patch
+++ b/gitahead.patch
@@ -1,18 +1,18 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b39f3a4..0b9b550 100644
+index 0dd8d38..c882a73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -61,7 +61,7 @@ endif()
+@@ -62,7 +62,7 @@ endif()
- find_package(Qt5 5.9 COMPONENTS ${QT_MODULES} LinguistTools REQUIRED)
+ find_package(Qt6 COMPONENTS ${QT_MODULES} LinguistTools REQUIRED)
--set(QT_TRANSLATIONS_DIR "${Qt5_DIR}/../../../translations")
+-set(QT_TRANSLATIONS_DIR "${Qt6_DIR}/../../../translations")
+set(QT_TRANSLATIONS_DIR "/usr/share/qt/translations")
if(APPLE)
foreach(QT_MODULE ${QT_MODULES})
diff --git a/dep/CMakeLists.txt b/dep/CMakeLists.txt
-index d589b6f..02e9035 100644
+index 16c7574..8295db2 100644
--- a/dep/CMakeLists.txt
+++ b/dep/CMakeLists.txt
@@ -1,6 +1,5 @@
@@ -23,7 +23,7 @@ index d589b6f..02e9035 100644
add_subdirectory(libgit2)
diff --git a/dep/libssh2/CMakeLists.txt b/dep/libssh2/CMakeLists.txt
-index d5ee005..6ca9e34 100644
+index 4062762..d4f2593 100644
--- a/dep/libssh2/CMakeLists.txt
+++ b/dep/libssh2/CMakeLists.txt
@@ -1,7 +1,7 @@
@@ -36,15 +36,15 @@ index d5ee005..6ca9e34 100644
set(BUILD_TESTING OFF CACHE BOOL "" FORCE)
diff --git a/pack/CMakeLists.txt b/pack/CMakeLists.txt
-index 61bd9fa..8338b7a 100644
+index dcb5964..df2d336 100644
--- a/pack/CMakeLists.txt
+++ b/pack/CMakeLists.txt
-@@ -139,7 +139,7 @@ if(UNIX AND NOT APPLE)
+@@ -145,7 +145,7 @@ if(UNIX AND NOT APPLE)
endif()
# Install SSL libraries.
-if(NOT APPLE)
+if(FALSE)
if(WIN32)
- if(CMAKE_SIZEOF_VOID_P EQUAL 8)
- set(SSL_LIB_SUFFIX "-1_1-x64.dll")
+ set(SSL_LIB_SUFFIX "-3-x64.dll")
+ else()