summarylogtreecommitdiffstats
path: root/glfw.patch
diff options
context:
space:
mode:
Diffstat (limited to 'glfw.patch')
-rw-r--r--glfw.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/glfw.patch b/glfw.patch
new file mode 100644
index 000000000000..5844c5414e49
--- /dev/null
+++ b/glfw.patch
@@ -0,0 +1,13 @@
+--- LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
++++ CMakeLists.txt 2018-05-13 12:50:20.599796898 +0200
+@@ -22,7 +22,10 @@
+ #
+ #############################################################################
+
+-add_subdirectory(deps/glfw-3.1.1)
++find_package(glfw3 REQUIRED)
++IF(NOT ${GLFW3_FOUND})
++ add_subdirectory(deps/glfw-3.1.1)
++ENDIF()
+ include_directories(deps/glfw-3.1.1/include)
+ include_directories(deps/nfd/include)