summarylogtreecommitdiffstats
path: root/gnupg-large-rsa-2.1.10.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnupg-large-rsa-2.1.10.patch')
-rw-r--r--gnupg-large-rsa-2.1.10.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnupg-large-rsa-2.1.10.patch b/gnupg-large-rsa-2.1.10.patch
new file mode 100644
index 000000000000..01819b826b07
--- /dev/null
+++ b/gnupg-large-rsa-2.1.10.patch
@@ -0,0 +1,53 @@
+diff -ru gnupg-2.1.10/configure gnupg-2.1.10-patched/configure
+--- gnupg-2.1.10/configure 2015-12-04 10:57:06.000000000 +0100
++++ gnupg-2.1.10-patched/configure 2016-01-26 14:55:11.000000000 +0100
+@@ -2861,7 +2861,7 @@
+
+ ac_config_headers="$ac_config_headers config.h"
+
+-am__api_version='1.14'
++am__api_version='1.15'
+
+ # Find a good install program. We prefer a C program (faster),
+ # so one script is as good as another. But avoid the broken or
+diff -ru gnupg-2.1.10/configure.ac gnupg-2.1.10-patched/configure.ac
+--- gnupg-2.1.10/configure.ac 2015-12-04 10:55:19.000000000 +0100
++++ gnupg-2.1.10-patched/configure.ac 2016-01-26 14:55:11.000000000 +0100
+@@ -19,7 +19,7 @@
+
+ # Process this file with autoconf to produce a configure script.
+ AC_PREREQ(2.61)
+-min_automake_version="1.14"
++min_automake_version="1.15"
+
+ # To build a release you need to create a tag with the version number
+ # (git tag -s gnupg-2.n.m) and run "./autogen.sh --force". Please
+@@ -234,7 +234,7 @@
+ large_secmem=$enableval, large_secmem=no)
+ AC_MSG_RESULT($large_secmem)
+ if test "$large_secmem" = yes ; then
+- SECMEM_BUFFER_SIZE=65536
++ SECMEM_BUFFER_SIZE=67108864
+ else
+ SECMEM_BUFFER_SIZE=32768
+ fi
+diff -ru gnupg-2.1.10/g10/keygen.c gnupg-2.1.10-patched/g10/keygen.c
+--- gnupg-2.1.10/g10/keygen.c 2015-12-04 10:53:27.000000000 +0100
++++ gnupg-2.1.10-patched/g10/keygen.c 2016-01-26 14:55:11.000000000 +0100
+@@ -1560,7 +1560,7 @@
+ int err;
+ char *keyparms;
+ char nbitsstr[35];
+- const unsigned maxsize = (opt.flags.large_rsa ? 8192 : 4096);
++ const unsigned maxsize = (opt.flags.large_rsa ? 14336 : 4096);
+
+ assert (is_RSA(algo));
+
+@@ -2054,6 +2054,7 @@
+
+ case PUBKEY_ALGO_RSA:
+ min=1024;
++ max = (opt.flags.large_rsa ? 14336 : 4096);
+ break;
+ }
+