summarylogtreecommitdiffstats
path: root/gtest-1.8.1-libversion.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gtest-1.8.1-libversion.patch')
-rw-r--r--gtest-1.8.1-libversion.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/gtest-1.8.1-libversion.patch b/gtest-1.8.1-libversion.patch
deleted file mode 100644
index a9c2c5f68492..000000000000
--- a/gtest-1.8.1-libversion.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
-index 8a8de1f..3d86a59 100644
---- a/googlemock/CMakeLists.txt
-+++ b/googlemock/CMakeLists.txt
-@@ -109,8 +109,10 @@ if (MSVC)
- else()
- cxx_library(gmock "${cxx_strict}" src/gmock-all.cc)
- target_link_libraries(gmock PUBLIC gtest)
-+ set_target_properties(gmock PROPERTIES VERSION __GOOGLETEST_VERSION__)
- cxx_library(gmock_main "${cxx_strict}" src/gmock_main.cc)
- target_link_libraries(gmock_main PUBLIC gmock)
-+ set_target_properties(gmock_main PROPERTIES VERSION __GOOGLETEST_VERSION__)
- endif()
- # If the CMake version supports it, attach header directory information
- # to the targets for when we are part of a parent build (ie being pulled
-diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
-index 9ee7940..8099130 100644
---- a/googletest/CMakeLists.txt
-+++ b/googletest/CMakeLists.txt
-@@ -131,7 +131,9 @@ endif()
- # are used for other targets, to ensure that gtest can be compiled by a user
- # aggressive about warnings.
- cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
-+set_target_properties(gtest PROPERTIES VERSION __GOOGLETEST_VERSION__)
- cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
-+set_target_properties(gtest_main PROPERTIES VERSION __GOOGLETEST_VERSION__)
- # If the CMake version supports it, attach header directory information
- # to the targets for when we are part of a parent build (ie being pulled
- # in via add_subdirectory() rather than being a standalone build).