summarylogtreecommitdiffstats
path: root/huggle-yaml.patch
diff options
context:
space:
mode:
Diffstat (limited to 'huggle-yaml.patch')
-rw-r--r--huggle-yaml.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/huggle-yaml.patch b/huggle-yaml.patch
new file mode 100644
index 000000000000..1eba4ed19bf9
--- /dev/null
+++ b/huggle-yaml.patch
@@ -0,0 +1,30 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index a37976e3..b7530e8f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -63,12 +63,19 @@ add_subdirectory(3rd/libirc/libirc libirc)
+ add_subdirectory(3rd/libirc/libircclient libircclient)
+
+ # YAML
+-option(YAML_CPP_BUILD_TOOLS "Disable tests" OFF)
+-option(YAML_CPP_BUILD_TESTS "Enable testing" OFF)
+-option(YAML_CPP_BUILD_TOOLS "Enable parse tools" OFF)
+-option(BUILD_SHARED_LIBS "Build as shared" ON)
+-include_directories("3rd/yaml-cpp/include/")
+-add_subdirectory(3rd/yaml-cpp)
++find_package(YAML-CPP 0.6.3 QUIET)
++if (YAML-CPP_FOUND)
++ message(STATUS "Using system yaml-cpp")
++ include_directories(YAML_CPP_INCLUDE_DIR)
++else()
++ option(YAML_CPP_BUILD_TOOLS "Disable tests" OFF)
++ option(YAML_CPP_BUILD_TESTS "Enable testing" OFF)
++ option(YAML_CPP_BUILD_TOOLS "Enable parse tools" OFF)
++ option(BUILD_SHARED_LIBS "Build as shared" ON)
++ include_directories("3rd/yaml-cpp/include/")
++ add_subdirectory(3rd/yaml-cpp)
++endif()
++
+ if (HUGGLE_EXT)
+ if(NOT MINGW AND WIN32)
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_CURRENT_BINARY_DIR}/Release/extensions)