summarylogtreecommitdiffstats
path: root/install.sh
diff options
context:
space:
mode:
Diffstat (limited to 'install.sh')
-rw-r--r--install.sh14
1 files changed, 13 insertions, 1 deletions
diff --git a/install.sh b/install.sh
index f010aa8af641..113425cf6953 100644
--- a/install.sh
+++ b/install.sh
@@ -1,16 +1,28 @@
update_vim_help() {
echo -n "Updating Vim help tags..."
/usr/bin/vim --noplugin -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" >/dev/null 2>&1
echo "done."
}
post_install() {
update_vim_help
+ echo "For rust support be sure to setup a default toolchain with rustup (and enable rust in PKGBUILD)"
+ echo "rls, rust-analysis and rust-src are needed for whatever toolchain you are using."
+ echo "Example:"
+ echo -e "\trustup toolchain install nightly"
+ echo -e "\trustup default nightly"
+ echo -e "\trustup component add rls rust-analysis rust-src"
}
post_upgrade() {
update_vim_help
+ echo "For rust support be sure to setup a default toolchain with rustup (and enable rust in PKGBUILD)"
+ echo "rls, rust-analysis and rust-src are needed for whatever toolchain you are using."
+ echo "Example:"
+ echo -e "\trustup toolchain install nightly"
+ echo -e "\trustup default nightly"
+ echo -e "\trustup component add rls rust-analysis rust-src"
}
post_remove() {