summarylogtreecommitdiffstats
path: root/intel-svt-hevc-fix-build-on-non-intel.patch
diff options
context:
space:
mode:
Diffstat (limited to 'intel-svt-hevc-fix-build-on-non-intel.patch')
-rw-r--r--intel-svt-hevc-fix-build-on-non-intel.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/intel-svt-hevc-fix-build-on-non-intel.patch b/intel-svt-hevc-fix-build-on-non-intel.patch
new file mode 100644
index 000000000000..4a2f77e449e2
--- /dev/null
+++ b/intel-svt-hevc-fix-build-on-non-intel.patch
@@ -0,0 +1,12 @@
+diff -Nawurp a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2019-02-14 00:36:54.000000000 +0000
++++ b/CMakeLists.txt 2019-06-14 22:55:19.335471333 +0000
+@@ -73,7 +73,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
+ endif()
+
+ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector-strong -fPIE -fPIC -D_FORTIFY_SOURCE=2 -O2 -flto -Wall -Wextra -Wformat -Wformat-security -fvisibility=hidden -march=native")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector-strong -fPIE -fPIC -D_FORTIFY_SOURCE=2 -O2 -flto -Wall -Wextra -Wformat -Wformat-security -fvisibility=hidden -mavx")
+ if(CMAKE_SYSTEM_NAME STREQUAL "Windows") #for Mingw64 support, see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65782
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-asynchronous-unwind-tables")
+ endif()