summarylogtreecommitdiffstats
path: root/jdupes-system-xxhash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'jdupes-system-xxhash.patch')
-rw-r--r--jdupes-system-xxhash.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/jdupes-system-xxhash.patch b/jdupes-system-xxhash.patch
new file mode 100644
index 000000000000..44dc991a71fa
--- /dev/null
+++ b/jdupes-system-xxhash.patch
@@ -0,0 +1,40 @@
+diff --git a/Makefile b/Makefile
+index 7e09923..df9566b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -126,7 +126,8 @@ ifdef USE_JODY_HASH
+ OBJS_CLEAN += xxhash.o
+ else
+ ifndef EXTERNAL_HASH_LIB
+- OBJS += xxhash.o
++ CFLAGS += `pkg-config --cflags libxxhash`
++ LDFLAGS += `pkg-config --libs libxxhash`
+ endif
+ endif # USE_JODY_HASH
+
+diff --git a/jdupes.c b/jdupes.c
+index e3e5762..bc66c05 100644
+--- a/jdupes.c
++++ b/jdupes.c
+@@ -62,7 +62,7 @@
+ #include "version.h"
+
+ #ifndef USE_JODY_HASH
+- #include "xxhash.h"
++ #include <xxhash.h>
+ #endif
+ #ifdef ENABLE_DEDUPE
+ #ifdef __linux__
+diff --git a/jdupes.h b/jdupes.h
+index 8b05d87..2975fbb 100644
+--- a/jdupes.h
++++ b/jdupes.h
+@@ -28,7 +28,7 @@ extern "C" {
+ #include <sys/types.h>
+
+ #ifndef USE_JODY_HASH
+-#include "xxhash.h"
++#include <xxhash.h>
+ #endif /* USE_JODY_HASH */
+
+ /* Set hash type (change this if swapping in a different hash function) */