summarylogtreecommitdiffstats
path: root/kill-canary.patch
diff options
context:
space:
mode:
Diffstat (limited to 'kill-canary.patch')
-rw-r--r--kill-canary.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/kill-canary.patch b/kill-canary.patch
new file mode 100644
index 000000000000..0ab52524e5f2
--- /dev/null
+++ b/kill-canary.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,8 +1,6 @@
+ use 5.010001; # for utf-8, and Time::Piece
+ use ExtUtils::MakeMaker;
+
+-use Canary::Stability CBOR::XS => 1, 5.010001;
+-
+ WriteMakefile(
+ dist => {
+ PREOP => 'pod2text XS.pm | tee README >$(DISTVNAME)/README; chmod -R u=rwX,go=rX . ;',
+@@ -15,6 +13,6 @@
+ common::sense => 0,
+ Types::Serialiser => 0,
+ },
+- CONFIGURE_REQUIRES => { ExtUtils::MakeMaker => 6.52, Canary::Stability => 0 },
++ CONFIGURE_REQUIRES => { ExtUtils::MakeMaker => 6.52 },
+ );
+