summarylogtreecommitdiffstats
path: root/libecwj2-3.3-missing_script_update.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libecwj2-3.3-missing_script_update.patch')
-rw-r--r--libecwj2-3.3-missing_script_update.patch491
1 files changed, 491 insertions, 0 deletions
diff --git a/libecwj2-3.3-missing_script_update.patch b/libecwj2-3.3-missing_script_update.patch
new file mode 100644
index 000000000000..f8f93b0db1ff
--- /dev/null
+++ b/libecwj2-3.3-missing_script_update.patch
@@ -0,0 +1,491 @@
+--- a/missing
++++ b/missing
+@@ -1,7 +1,10 @@
+ #! /bin/sh
+-# Common stub for a few missing GNU programs while installing.
+-# Copyright (C) 1996, 1997, 1999, 2000, 2002, 2003 Free Software Foundation, Inc.
+-# Originally by Fran,cois Pinard <pinard@iro.umontreal.ca>, 1996.
++# Common wrapper for a few potentially missing GNU programs.
++
++scriptversion=2018-03-07.03; # UTC
++
++# Copyright (C) 1996-2018 Free Software Foundation, Inc.
++# Originally written by Fran,cois Pinard <pinard@iro.umontreal.ca>, 1996.
+
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -14,9 +17,7 @@
+ # GNU General Public License for more details.
+
+ # You should have received a copy of the GNU General Public License
+-# along with this program; if not, write to the Free Software
+-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+-# 02111-1307, USA.
++# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ # As a special exception to the GNU General Public License, if you
+ # distribute this file as part of a program that contains a
+@@ -24,313 +25,191 @@
+ # the same distribution terms that you use for the rest of that program.
+
+ if test $# -eq 0; then
+- echo 1>&2 "Try \`$0 --help' for more information"
++ echo 1>&2 "Try '$0 --help' for more information"
+ exit 1
+ fi
+
+-run=:
+-
+-# In the cases where this matters, `missing' is being run in the
+-# srcdir already.
+-if test -f configure.ac; then
+- configure_ac=configure.ac
+-else
+- configure_ac=configure.in
+-fi
++case $1 in
+
+-case "$1" in
+---run)
+- # Try to run requested program, and just exit if it succeeds.
+- run=
+- shift
+- "$@" && exit 0
+- ;;
+-esac
++ --is-lightweight)
++ # Used by our autoconf macros to check whether the available missing
++ # script is modern enough.
++ exit 0
++ ;;
+
+-# If it does not exist, or fails to run (possibly an outdated version),
+-# try to emulate it.
+-case "$1" in
++ --run)
++ # Back-compat with the calling convention used by older automake.
++ shift
++ ;;
+
+ -h|--h|--he|--hel|--help)
+ echo "\
+ $0 [OPTION]... PROGRAM [ARGUMENT]...
+
+-Handle \`PROGRAM [ARGUMENT]...' for when PROGRAM is missing, or return an
+-error status if there is no known handling for PROGRAM.
++Run 'PROGRAM [ARGUMENT]...', returning a proper advice when this fails due
++to PROGRAM being missing or too old.
+
+ Options:
+ -h, --help display this help and exit
+ -v, --version output version information and exit
+- --run try to run the given command, and emulate it if it fails
+
+ Supported PROGRAM values:
+- aclocal touch file \`aclocal.m4'
+- autoconf touch file \`configure'
+- autoheader touch file \`config.h.in'
+- automake touch all \`Makefile.in' files
+- bison create \`y.tab.[ch]', if possible, from existing .[ch]
+- flex create \`lex.yy.c', if possible, from existing .c
+- help2man touch the output file
+- lex create \`lex.yy.c', if possible, from existing .c
+- makeinfo touch the output file
+- tar try tar, gnutar, gtar, then tar without non-portable flags
+- yacc create \`y.tab.[ch]', if possible, from existing .[ch]"
++ aclocal autoconf autoheader autom4te automake makeinfo
++ bison yacc flex lex help2man
++
++Version suffixes to PROGRAM as well as the prefixes 'gnu-', 'gnu', and
++'g' are ignored when checking the name.
++
++Send bug reports to <bug-automake@gnu.org>."
++ exit $?
+ ;;
+
+ -v|--v|--ve|--ver|--vers|--versi|--versio|--version)
+- echo "missing 0.4 - GNU automake"
++ echo "missing $scriptversion (GNU Automake)"
++ exit $?
+ ;;
+
+ -*)
+- echo 1>&2 "$0: Unknown \`$1' option"
+- echo 1>&2 "Try \`$0 --help' for more information"
++ echo 1>&2 "$0: unknown '$1' option"
++ echo 1>&2 "Try '$0 --help' for more information"
+ exit 1
+ ;;
+
+- aclocal*)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
+-
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified \`acinclude.m4' or \`${configure_ac}'. You might want
+- to install the \`Automake' and \`Perl' packages. Grab them from
+- any GNU archive site."
+- touch aclocal.m4
+- ;;
+-
+- autoconf)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
+-
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified \`${configure_ac}'. You might want to install the
+- \`Autoconf' and \`GNU m4' packages. Grab them from any GNU
+- archive site."
+- touch configure
+- ;;
+-
+- autoheader)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
+-
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified \`acconfig.h' or \`${configure_ac}'. You might want
+- to install the \`Autoconf' and \`GNU m4' packages. Grab them
+- from any GNU archive site."
+- files=`sed -n 's/^[ ]*A[CM]_CONFIG_HEADER(\([^)]*\)).*/\1/p' ${configure_ac}`
+- test -z "$files" && files="config.h"
+- touch_files=
+- for f in $files; do
+- case "$f" in
+- *:*) touch_files="$touch_files "`echo "$f" |
+- sed -e 's/^[^:]*://' -e 's/:.*//'`;;
+- *) touch_files="$touch_files $f.in";;
+- esac
+- done
+- touch $touch_files
+- ;;
+-
+- automake*)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
+-
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified \`Makefile.am', \`acinclude.m4' or \`${configure_ac}'.
+- You might want to install the \`Automake' and \`Perl' packages.
+- Grab them from any GNU archive site."
+- find . -type f -name Makefile.am -print |
+- sed 's/\.am$/.in/' |
+- while read f; do touch "$f"; done
+- ;;
+-
+- autom4te)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
++esac
+
+- echo 1>&2 "\
+-WARNING: \`$1' is needed, and you do not seem to have it handy on your
+- system. You might have modified some files without having the
+- proper tools for further handling them.
+- You can get \`$1' as part of \`Autoconf' from any GNU
+- archive site."
++# Run the given program, remember its exit status.
++"$@"; st=$?
+
+- file=`echo "$*" | sed -n 's/.*--output[ =]*\([^ ]*\).*/\1/p'`
+- test -z "$file" && file=`echo "$*" | sed -n 's/.*-o[ ]*\([^ ]*\).*/\1/p'`
+- if test -f "$file"; then
+- touch $file
+- else
+- test -z "$file" || exec >$file
+- echo "#! /bin/sh"
+- echo "# Created by GNU Automake missing as a replacement of"
+- echo "# $ $@"
+- echo "exit 0"
+- chmod +x $file
+- exit 1
+- fi
+- ;;
++# If it succeeded, we are done.
++test $st -eq 0 && exit 0
+
+- bison|yacc)
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified a \`.y' file. You may need the \`Bison' package
+- in order for those modifications to take effect. You can get
+- \`Bison' from any GNU archive site."
+- rm -f y.tab.c y.tab.h
+- if [ $# -ne 1 ]; then
+- eval LASTARG="\${$#}"
+- case "$LASTARG" in
+- *.y)
+- SRCFILE=`echo "$LASTARG" | sed 's/y$/c/'`
+- if [ -f "$SRCFILE" ]; then
+- cp "$SRCFILE" y.tab.c
+- fi
+- SRCFILE=`echo "$LASTARG" | sed 's/y$/h/'`
+- if [ -f "$SRCFILE" ]; then
+- cp "$SRCFILE" y.tab.h
+- fi
+- ;;
+- esac
+- fi
+- if [ ! -f y.tab.h ]; then
+- echo >y.tab.h
+- fi
+- if [ ! -f y.tab.c ]; then
+- echo 'main() { return 0; }' >y.tab.c
+- fi
+- ;;
++# Also exit now if we it failed (or wasn't found), and '--version' was
++# passed; such an option is passed most likely to detect whether the
++# program is present and works.
++case $2 in --version|--help) exit $st;; esac
+
+- lex|flex)
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified a \`.l' file. You may need the \`Flex' package
+- in order for those modifications to take effect. You can get
+- \`Flex' from any GNU archive site."
+- rm -f lex.yy.c
+- if [ $# -ne 1 ]; then
+- eval LASTARG="\${$#}"
+- case "$LASTARG" in
+- *.l)
+- SRCFILE=`echo "$LASTARG" | sed 's/l$/c/'`
+- if [ -f "$SRCFILE" ]; then
+- cp "$SRCFILE" lex.yy.c
+- fi
+- ;;
+- esac
+- fi
+- if [ ! -f lex.yy.c ]; then
+- echo 'main() { return 0; }' >lex.yy.c
+- fi
+- ;;
++# Exit code 63 means version mismatch. This often happens when the user
++# tries to use an ancient version of a tool on a file that requires a
++# minimum version.
++if test $st -eq 63; then
++ msg="probably too old"
++elif test $st -eq 127; then
++ # Program was missing.
++ msg="missing on your system"
++else
++ # Program was found and executed, but failed. Give up.
++ exit $st
++fi
+
+- help2man)
+- if test -z "$run" && ($1 --version) > /dev/null 2>&1; then
+- # We have it, but it failed.
+- exit 1
+- fi
++perl_URL=https://www.perl.org/
++flex_URL=https://github.com/westes/flex
++gnu_software_URL=https://www.gnu.org/software
+
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified a dependency of a manual page. You may need the
+- \`Help2man' package in order for those modifications to take
+- effect. You can get \`Help2man' from any GNU archive site."
++program_details ()
++{
++ case $1 in
++ aclocal|automake)
++ echo "The '$1' program is part of the GNU Automake package:"
++ echo "<$gnu_software_URL/automake>"
++ echo "It also requires GNU Autoconf, GNU m4 and Perl in order to run:"
++ echo "<$gnu_software_URL/autoconf>"
++ echo "<$gnu_software_URL/m4/>"
++ echo "<$perl_URL>"
++ ;;
++ autoconf|autom4te|autoheader)
++ echo "The '$1' program is part of the GNU Autoconf package:"
++ echo "<$gnu_software_URL/autoconf/>"
++ echo "It also requires GNU m4 and Perl in order to run:"
++ echo "<$gnu_software_URL/m4/>"
++ echo "<$perl_URL>"
++ ;;
++ esac
++}
+
+- file=`echo "$*" | sed -n 's/.*-o \([^ ]*\).*/\1/p'`
+- if test -z "$file"; then
+- file=`echo "$*" | sed -n 's/.*--output=\([^ ]*\).*/\1/p'`
+- fi
+- if [ -f "$file" ]; then
+- touch $file
+- else
+- test -z "$file" || exec >$file
+- echo ".ab help2man is required to generate this page"
+- exit 1
+- fi
+- ;;
++give_advice ()
++{
++ # Normalize program name to check for.
++ normalized_program=`echo "$1" | sed '
++ s/^gnu-//; t
++ s/^gnu//; t
++ s/^g//; t'`
+
+- makeinfo)
+- if test -z "$run" && (makeinfo --version) > /dev/null 2>&1; then
+- # We have makeinfo, but it failed.
+- exit 1
+- fi
++ printf '%s\n' "'$1' is $msg."
+
+- echo 1>&2 "\
+-WARNING: \`$1' is missing on your system. You should only need it if
+- you modified a \`.texi' or \`.texinfo' file, or any other file
+- indirectly affecting the aspect of the manual. The spurious
+- call might also be the consequence of using a buggy \`make' (AIX,
+- DU, IRIX). You might want to install the \`Texinfo' package or
+- the \`GNU make' package. Grab either from any GNU archive site."
+- file=`echo "$*" | sed -n 's/.*-o \([^ ]*\).*/\1/p'`
+- if test -z "$file"; then
+- file=`echo "$*" | sed 's/.* \([^ ]*\) *$/\1/'`
+- file=`sed -n '/^@setfilename/ { s/.* \([^ ]*\) *$/\1/; p; q; }' $file`
+- fi
+- touch $file
++ configure_deps="'configure.ac' or m4 files included by 'configure.ac'"
++ case $normalized_program in
++ autoconf*)
++ echo "You should only need it if you modified 'configure.ac',"
++ echo "or m4 files included by it."
++ program_details 'autoconf'
++ ;;
++ autoheader*)
++ echo "You should only need it if you modified 'acconfig.h' or"
++ echo "$configure_deps."
++ program_details 'autoheader'
++ ;;
++ automake*)
++ echo "You should only need it if you modified 'Makefile.am' or"
++ echo "$configure_deps."
++ program_details 'automake'
++ ;;
++ aclocal*)
++ echo "You should only need it if you modified 'acinclude.m4' or"
++ echo "$configure_deps."
++ program_details 'aclocal'
++ ;;
++ autom4te*)
++ echo "You might have modified some maintainer files that require"
++ echo "the 'autom4te' program to be rebuilt."
++ program_details 'autom4te'
++ ;;
++ bison*|yacc*)
++ echo "You should only need it if you modified a '.y' file."
++ echo "You may want to install the GNU Bison package:"
++ echo "<$gnu_software_URL/bison/>"
++ ;;
++ lex*|flex*)
++ echo "You should only need it if you modified a '.l' file."
++ echo "You may want to install the Fast Lexical Analyzer package:"
++ echo "<$flex_URL>"
++ ;;
++ help2man*)
++ echo "You should only need it if you modified a dependency" \
++ "of a man page."
++ echo "You may want to install the GNU Help2man package:"
++ echo "<$gnu_software_URL/help2man/>"
+ ;;
++ makeinfo*)
++ echo "You should only need it if you modified a '.texi' file, or"
++ echo "any other file indirectly affecting the aspect of the manual."
++ echo "You might want to install the Texinfo package:"
++ echo "<$gnu_software_URL/texinfo/>"
++ echo "The spurious makeinfo call might also be the consequence of"
++ echo "using a buggy 'make' (AIX, DU, IRIX), in which case you might"
++ echo "want to install GNU make:"
++ echo "<$gnu_software_URL/make/>"
++ ;;
++ *)
++ echo "You might have modified some files without having the proper"
++ echo "tools for further handling them. Check the 'README' file, it"
++ echo "often tells you about the needed prerequisites for installing"
++ echo "this package. You may also peek at any GNU archive site, in"
++ echo "case some other package contains this missing '$1' program."
++ ;;
++ esac
++}
+
+- tar)
+- shift
+- if test -n "$run"; then
+- echo 1>&2 "ERROR: \`tar' requires --run"
+- exit 1
+- fi
+-
+- # We have already tried tar in the generic part.
+- # Look for gnutar/gtar before invocation to avoid ugly error
+- # messages.
+- if (gnutar --version > /dev/null 2>&1); then
+- gnutar "$@" && exit 0
+- fi
+- if (gtar --version > /dev/null 2>&1); then
+- gtar "$@" && exit 0
+- fi
+- firstarg="$1"
+- if shift; then
+- case "$firstarg" in
+- *o*)
+- firstarg=`echo "$firstarg" | sed s/o//`
+- tar "$firstarg" "$@" && exit 0
+- ;;
+- esac
+- case "$firstarg" in
+- *h*)
+- firstarg=`echo "$firstarg" | sed s/h//`
+- tar "$firstarg" "$@" && exit 0
+- ;;
+- esac
+- fi
+-
+- echo 1>&2 "\
+-WARNING: I can't seem to be able to run \`tar' with the given arguments.
+- You may want to install GNU tar or Free paxutils, or check the
+- command line arguments."
+- exit 1
+- ;;
++give_advice "$1" | sed -e '1s/^/WARNING: /' \
++ -e '2,$s/^/ /' >&2
+
+- *)
+- echo 1>&2 "\
+-WARNING: \`$1' is needed, and you do not seem to have it handy on your
+- system. You might have modified some files without having the
+- proper tools for further handling them. Check the \`README' file,
+- it often tells you about the needed prerequisites for installing
+- this package. You may also peek at any GNU archive site, in case
+- some other package would contain this missing \`$1' program."
+- exit 1
+- ;;
+-esac
++# Propagate the correct exit status (expected to be 127 for a program
++# not found, 63 for a program that failed due to version mismatch).
++exit $st
+
+-exit 0
++# Local variables:
++# eval: (add-hook 'before-save-hook 'time-stamp)
++# time-stamp-start: "scriptversion="
++# time-stamp-format: "%:y-%02m-%02d.%02H"
++# time-stamp-time-zone: "UTC0"
++# time-stamp-end: "; # UTC"
++# End: