summarylogtreecommitdiffstats
path: root/liblua.so.patch
diff options
context:
space:
mode:
Diffstat (limited to 'liblua.so.patch')
-rw-r--r--liblua.so.patch47
1 files changed, 16 insertions, 31 deletions
diff --git a/liblua.so.patch b/liblua.so.patch
index 9217e34d6083..19d6310b2a46 100644
--- a/liblua.so.patch
+++ b/liblua.so.patch
@@ -1,29 +1,27 @@
-diff --git a/Makefile b/Makefile
-index 7fa91c8..dccf485 100644
---- a/Makefile
-+++ b/Makefile
-@@ -52,7 +52,7 @@ R= $V.0
+diff -ruN a/Makefile b/Makefile
+--- a/Makefile 2020-04-15 09:55:07.000000000 -0300
++++ b/Makefile 2020-04-18 10:31:59.424670791 -0300
+@@ -52,7 +52,7 @@
all: $(PLAT)
- $(PLATS) clean:
-- cd src && $(MAKE) $@
-+ cd src && $(MAKE) $@ V=$(V) R=$(R)
+ $(PLATS) help test clean:
+- @cd src && $(MAKE) $@
++ @cd src && $(MAKE) $@ V=$(V) R=$(R)
- test: dummy
- src/lua -v
-diff --git a/src/Makefile b/src/Makefile
-index 2e7a412..fa5769f 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -29,6 +29,7 @@
- PLATS= aix bsd c89 freebsd generic guess linux linux-readline macosx mingw posix solaris
+ install: dummy
+ cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
+diff -ruN a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2020-04-15 10:00:29.000000000 -0300
++++ b/src/Makefile 2020-04-18 10:33:15.608253222 -0300
+@@ -33,6 +33,7 @@
+ PLATS= guess aix bsd c89 freebsd generic linux linux-readline macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o lundump.o lvm.o lzio.o
LIB_O= lauxlib.o lbaselib.o lcorolib.o ldblib.o liolib.o lmathlib.o loadlib.o loslib.o lstrlib.o ltablib.o lutf8lib.o linit.o
BASE_O= $(CORE_O) $(LIB_O) $(MYOBJS)
-@@ -40,7 +41,7 @@
+@@ -44,7 +45,7 @@
LUAC_O= luac.o
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
@@ -32,7 +30,7 @@ index 2e7a412..fa5769f 100644
ALL_A= $(LUA_A)
# Targets start here.
-@@ -56,6 +57,11 @@
+@@ -60,6 +61,11 @@
$(AR) $@ $(BASE_O)
$(RANLIB) $@
@@ -44,16 +42,3 @@ index 2e7a412..fa5769f 100644
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-diff --git a/src/luaconf.h b/src/luaconf.h
-index fd28d21..e2662cc 100644
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -175,7 +175,7 @@
-
- #else /* }{ */
-
--#define LUA_ROOT "/usr/local/"
-+#define LUA_ROOT "/usr/"
- #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/"
- #define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/"
- #define LUA_PATH_DEFAULT \ \ No newline at end of file