summarylogtreecommitdiffstats
path: root/libm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libm.patch')
-rw-r--r--libm.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/libm.patch b/libm.patch
new file mode 100644
index 000000000000..39c6a5f6bb90
--- /dev/null
+++ b/libm.patch
@@ -0,0 +1,30 @@
+Description: Arch Linux, phlipple-svn (AUR) package.
+ This patch obtaied from Debian sources.
+ Here is a description from original patch.
+ ------------------------------------------
+ Link with libm for cos().
+ This is fallout from the fact that other libraries in Debian, such as
+ libvorbisfile, no longer include their own dependencies in the pkg-config
+ output. Until now, phlipple built just fine because -lm was added by
+ other libraries; now it has to add it on its own.
+ .
+ This bug should really be fixed upstream by adding an explicit check for
+ cos(3) in configure.ac, something like AC_CHECK_LIB([m], [cos])
+ I do intend to do that in a future upload, but IMHO this minimal patch
+ ought to be suitable for the Jessie freeze.
+Debian-Bug: https://bugs.debian.org/768741
+Author: Peter Pentchev <roam@ringlet.net>
+Forwarded: not-yet
+Last-Update: 2014-11-10
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -233,7 +233,7 @@
+ vertex.h
+
+ phlipple_LDFLAGS =
+-phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS)
++phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS) -lm
+ all: all-am
+
+ .SUFFIXES: