summarylogtreecommitdiffstats
path: root/libseekthermal.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libseekthermal.patch')
-rw-r--r--libseekthermal.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/libseekthermal.patch b/libseekthermal.patch
new file mode 100644
index 000000000000..ce94000cddd7
--- /dev/null
+++ b/libseekthermal.patch
@@ -0,0 +1,65 @@
+diff -ura libseekthermal.orig/CMakeLists.txt libseekthermal.new/CMakeLists.txt
+--- libseekthermal.orig/CMakeLists.txt 2019-01-15 07:01:20.088124744 -0500
++++ libseekthermal.new/CMakeLists.txt 2019-01-15 07:11:04.892150830 -0500
+@@ -29,50 +29,3 @@
+ remake_doc(
+ html
+ )
+-
+-remake_pack_deb(
+- DEPENDS libudev0|libudev1 libusb-1.0-0 libboost-chrono[0-9.]*
+-)
+-remake_pack_deb(
+- COMPONENT utils
+- DESCRIPTION "utilities"
+- DEPENDS libseekthermal libpng12-0
+-)
+-remake_pack_deb(
+- COMPONENT gui
+- DESCRIPTION "GUI"
+- DEPENDS libseekthermal libqtgui4
+-)
+-remake_pack_deb(
+- COMPONENT dev
+- DESCRIPTION "development headers"
+- DEPENDS libseekthermal
+-)
+-remake_pack_deb(
+- COMPONENT udev
+- DESCRIPTION "udev rules"
+- DEPENDS udev
+- EXTRA debian/rules/*
+-)
+-remake_pack_deb(
+- ARCH all
+- COMPONENT doc
+- DESCRIPTION "documentation"
+-)
+-
+-remake_distribute_deb(
+- DISTRIBUTION precise
+- SECTION libs
+- UPLOAD ppa:kralf/asl
+- DEPENDS libboost-chrono1.48-dev libudev-dev libusb-1.0-0-dev
+- libpng12-dev libqt4-dev remake doxygen pkg-config
+- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
+-)
+-remake_distribute_deb(
+- DISTRIBUTION trusty
+- SECTION libs
+- UPLOAD ppa:kralf/asl
+- DEPENDS libboost-chrono-dev libudev-dev libusb-1.0-0-dev
+- libpng12-dev libqt4-dev remake doxygen pkg-config
+- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
+-)
+diff -ura libseekthermal.orig/src/bin/gui/view.cpp libseekthermal.new/src/bin/gui/view.cpp
+--- libseekthermal.orig/src/bin/gui/view.cpp 2019-01-15 07:01:20.088124744 -0500
++++ libseekthermal.new/src/bin/gui/view.cpp 2019-01-15 07:13:23.432931063 -0500
+@@ -18,6 +18,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cmath>
+ #include <iostream>
+ #include <csignal>
+ #include <limits>