summarylogtreecommitdiffstats
path: root/link-X11.patch
diff options
context:
space:
mode:
Diffstat (limited to 'link-X11.patch')
-rw-r--r--link-X11.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/link-X11.patch b/link-X11.patch
new file mode 100644
index 000000000000..32ba00d0f34f
--- /dev/null
+++ b/link-X11.patch
@@ -0,0 +1,11 @@
+--- wiLink-2.4.2/src/app/CMakeLists.txt.orig 2013-03-12 09:55:15.000000000 +0100
++++ wiLink-2.4.2/src/app/CMakeLists.txt 2013-06-26 15:27:29.000000000 +0200
+@@ -19,6 +19,8 @@
+ if(APPLE)
+ list(APPEND app_SOURCES application_mac.mm)
+ list(APPEND app_LIBRARIES "-framework AppKit")
++elseif(UNIX)
++ list(APPEND app_LIBRARIES X11)
+ endif()
+
+ qt4_wrap_cpp(app_MOC_SOURCES ${app_MOC_HEADERS})