summarylogtreecommitdiffstats
path: root/lua51.patch
diff options
context:
space:
mode:
Diffstat (limited to 'lua51.patch')
-rw-r--r--lua51.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/lua51.patch b/lua51.patch
deleted file mode 100644
index a198e72ddbcf..000000000000
--- a/lua51.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/CMake/FindLuaInterp.cmake 2016-07-15 02:29:39.418795763 +0800
-+++ b/CMake/FindLuaInterp.cmake 2016-07-15 02:29:45.812129311 +0800
-@@ -11,7 +11,7 @@
- # LUA_EXECUTABLE_VERSION_STRING - version of lua found
-
- find_program(LUA_EXECUTABLE
-- NAMES lua
-+ NAMES lua5.1 lua
- )
-
- if(LUA_EXECUTABLE)
---- a/Wrapping/Lua/CMakeLists.txt 2016-07-15 02:21:14.748778896 +0800
-+++ Wrapping/Lua/CMakeLists.txt.orig 2016-07-15 02:20:55.322111581 +0800
-@@ -5,7 +5,7 @@
- include(../../CMake/sitkProjectLanguageCommon.cmake)
-
-
--find_package ( Lua REQUIRED )
-+find_package ( Lua51 REQUIRED )
-
- set( LUA_ADDITIONAL_LIBRARIES "" CACHE STRING "Additional libraries which may be needed for lua executable such as readline.")
- mark_as_advanced( LUA_ADDITIONAL_LIBRARIES )
---- a/CMake/sitkLanguageOptions.cmake 2016-07-15 17:56:50.830654990 +0800
-+++ b/CMake/sitkLanguageOptions.cmake 2016-07-15 17:57:23.547322749 +0800
-@@ -31,9 +31,9 @@
- # Setup the option for each language
- #
- set_QUIET( WRAP_LUA )
--find_package ( Lua ${_QUIET} )
--
--if ( LUA_FOUND )
-+find_package ( Lua51 ${_QUIET} )
-+
-+if ( LUA51_FOUND )
- set( WRAP_LUA_DEFAULT ${WRAP_DEFAULT} )
- else()
- set( WRAP_LUA_DEFAULT OFF )