summarylogtreecommitdiffstats
path: root/macro-quotation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'macro-quotation.patch')
-rw-r--r--macro-quotation.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/macro-quotation.patch b/macro-quotation.patch
new file mode 100644
index 000000000000..c5e1b6afc3f4
--- /dev/null
+++ b/macro-quotation.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -188,7 +188,7 @@
+
+ ALL_PROGRAMS =
+
+-CPPFLAGS = -DBINTOPKGLIBEXECDIR='"'$(shell sh tools/rel.sh $(bindir) $(pkglibexecdir))'"'
++CPPFLAGS = -DBINTOPKGLIBEXECDIR="\"$(shell sh tools/rel.sh $(bindir) $(pkglibexecdir))\""
+ CFLAGS = $(CPPFLAGS) $(CWARNFLAGS) $(CDEBUGFLAGS) $(COPTFLAGS) -I $(CCANDIR) $(EXTERNAL_INCLUDE_FLAGS) -I . -I/usr/local/include $(FEATURES) $(COVFLAGS) $(DEV_CFLAGS) -DSHACHAIN_BITS=48 -DJSMN_PARENT_LINKS $(PIE_CFLAGS) $(COMPAT_CFLAGS)
+
+ # We can get configurator to run a different compile cmd to cross-configure.