summarylogtreecommitdiffstats
path: root/make-check
diff options
context:
space:
mode:
Diffstat (limited to 'make-check')
-rwxr-xr-xmake-check21
1 files changed, 21 insertions, 0 deletions
diff --git a/make-check b/make-check
new file mode 100755
index 000000000000..d21afdb28ff7
--- /dev/null
+++ b/make-check
@@ -0,0 +1,21 @@
+#!/bin/bash
+
+# A convenience script for the package creator.
+# This file is not run on package installation.
+
+PACMAN=
+PATH=/usr/bin:$PATH
+
+pkgdir=${0%%/*} # dirname $0
+cd -P -- "$pkgdir" || exit 1 # Allow to be called from any directory
+
+if [[ -d src ]]; then
+ makepkg -ef
+else
+ makepkg -f
+fi
+
+namcap PKGBUILD
+namcap ./*.tar.xz
+
+makepkg --printsrcinfo >| .SRCINFO && echo "Updated .SRCINFO" >&2