summarylogtreecommitdiffstats
path: root/make-destdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'make-destdir.patch')
-rw-r--r--make-destdir.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/make-destdir.patch b/make-destdir.patch
new file mode 100644
index 000000000000..3109f866bb4c
--- /dev/null
+++ b/make-destdir.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index 1239b9f..764bd65 100644
+--- a/Makefile
++++ b/Makefile
+@@ -15,9 +15,9 @@ SHARE = share
+
+ # Install variables:
+ PREFIX ?= /usr/local
+-INSTALL_LIB ?= $(shell git --exec-path)
++INSTALL_LIB ?= $(DESTDIR)$(shell git --exec-path)
+ INSTALL_EXT ?= $(INSTALL_LIB)/$(NAME).d
+-INSTALL_MAN1 ?= $(PREFIX)/share/man/man1
++INSTALL_MAN1 ?= $(DESTDIR)$(PREFIX)/share/man/man1
+
+ # Basic targets:
+ default: help
+@@ -36,6 +36,7 @@ test:
+
+ # Install support:
+ install:
++ install -C -d -m 0755 $(INSTALL_LIB)/
+ install -C -m 0755 $(LIB) $(INSTALL_LIB)/
+ install -C -d -m 0755 $(INSTALL_EXT)/
+ install -C -m 0755 $(EXTS) $(INSTALL_EXT)/