summarylogtreecommitdiffstats
path: root/make-release.py
diff options
context:
space:
mode:
Diffstat (limited to 'make-release.py')
-rw-r--r--make-release.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/make-release.py b/make-release.py
index 7fb158a87e8c..3f672e49aaf5 100644
--- a/make-release.py
+++ b/make-release.py
@@ -61,8 +61,9 @@ def run_makepkg():
def update_srcinfo():
- cmd = ["mksrcinfo"]
- subprocess.check_call(cmd, cwd=THIS_DIR)
+ cmd = ["makepkg", "--printsrcinfo"]
+ with open(".SRCINFO", "w") as fp:
+ subprocess.check_call(cmd, cwd=THIS_DIR, stdout=fp)
def commit_all(version):
cmd = ["git", "add", "PKGBUILD", ".SRCINFO"]