summarylogtreecommitdiffstats
path: root/makefile-system-htslib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefile-system-htslib.patch')
-rw-r--r--makefile-system-htslib.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
deleted file mode 100644
index 7e98ae5d9f98..000000000000
--- a/makefile-system-htslib.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- Makefile.orig 2017-03-14 07:26:49.191430557 +0100
-+++ Makefile 2017-03-14 07:27:44.929678345 +0100
-@@ -29,20 +29,10 @@
- all: $(PROG) $(TEST_PROG)
-
- # Adjust $(HTSDIR) to point to your top-level htslib directory
--HTSDIR = htslib-1.4.1
--include $(HTSDIR)/htslib.mk
--include $(HTSDIR)/htslib_static.mk
--HTSLIB = $(HTSDIR)/libhts.a
--BGZIP = $(HTSDIR)/bgzip
--TABIX = $(HTSDIR)/tabix
--HTSLIB_LDFLAGS = $(HTSLIB_static_LDFLAGS)
--HTSLIB_LIBS = $(HTSLIB_static_LIBS)
-+HTSDIR = /usr/include
-
- CC = gcc
--CPPFLAGS =
--CFLAGS = -g -Wall -Wc++-compat -O2
--LDFLAGS =
--LIBS =
-+CFLAGS := -g -Wall -Wc++-compat -O2 $(CFLAGS)
-
- ifeq "$(shell uname -s)" "Darwin"
- DYNAMIC_FLAGS = -Wl,-export_dynamic
-@@ -51,8 +41,8 @@
- endif
-
- # TODO Use configure or htslib.pc to add -rdynamic/-ldl conditionally
--ALL_CPPFLAGS = -I. $(HTSLIB_CPPFLAGS) $(CPPFLAGS)
--ALL_LDFLAGS = $(DYNAMIC_FLAGS) $(HTSLIB_LDFLAGS) $(LDFLAGS)
-+ALL_CPPFLAGS = -I. $(CPPFLAGS)
-+ALL_LDFLAGS = $(DYNAMIC_FLAGS) $(LDFLAGS)
- ALL_LIBS = -lm -lz -ldl $(LIBS)
-
- OBJS = main.o vcfindex.o tabix.o \
-@@ -64,7 +54,7 @@
- mpileup.o bam2bcf.o bam2bcf_indel.o bam_sample.o \
- ccall.o em.o prob1.o kmin.o # the original samtools calling
-
--EXTRA_CPPFLAGS = -I. -I$(HTSDIR) -DPLUGINPATH=\"$(pluginpath)\"
-+EXTRA_CPPFLAGS = -I. -DPLUGINPATH=\"$(pluginpath)\"
- GSL_LIBS =
-
- # The polysomy command is not compiled by default because it brings dependency
-@@ -73,7 +63,7 @@
- ifdef USE_GPL
- EXTRA_CPPFLAGS += -DUSE_GPL
- OBJS += polysomy.o peakfit.o
-- GSL_LIBS = -lgsl -lcblas
-+ GSL_LIBS = -lgsl -lgslcblas
- endif
-
- prefix = /usr/local
-@@ -117,12 +107,12 @@
- .c.o:
- $(CC) $(CFLAGS) $(EXTRA_CPPFLAGS) $(ALL_CPPFLAGS) -c -o $@ $<
-
--test: $(PROG) plugins test/test-rbuf test/test-regidx $(BGZIP) $(TABIX)
-+test: $(PROG) plugins test/test-rbuf test/test-regidx
- ./test/test-regidx
-- ./test/test.pl --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
-+ ./test/test.pl --exec bgzip=bgzip --exec tabix=tabix
-
--test-plugins: $(PROG) plugins test/test-rbuf $(BGZIP) $(TABIX)
-- ./test/test.pl --plugins --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
-+test-plugins: $(PROG) plugins test/test-rbuf
-+ ./test/test.pl --plugins --exec bgzip=bgzip --exec tabix=tabix
-
-
- # Plugin rules
-@@ -208,11 +198,11 @@
-
- test/test-regidx.o: test/test-regidx.c regidx.h
-
--test/test-regidx: test/test-regidx.o regidx.o $(HTSLIB)
-- $(CC) $(ALL_LDFLAGS) -o $@ $^ $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(ALL_LIBS)
-+test/test-regidx: test/test-regidx.o regidx.o
-+ $(CC) $(ALL_LDFLAGS) -o $@ $^ -lpthread -lhts $(ALL_LIBS)
-
--bcftools: $(HTSLIB) $(OBJS)
-- $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(GSL_LIBS) $(ALL_LIBS)
-+bcftools: $(OBJS)
-+ $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) -lpthread -lhts $(GSL_LIBS) $(ALL_LIBS)
-
- doc/bcftools.1: doc/bcftools.txt
- cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt