summarylogtreecommitdiffstats
path: root/makefile-system-htslib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefile-system-htslib.patch')
-rw-r--r--makefile-system-htslib.patch79
1 files changed, 13 insertions, 66 deletions
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
index 91056165a424..7ae2b4c6f295 100644
--- a/makefile-system-htslib.patch
+++ b/makefile-system-htslib.patch
@@ -1,16 +1,18 @@
---- /tmp/bcftools-1.3/Makefile 2015-12-15 22:58:35.000000000 +0100
-+++ /tmp/makepkg/bcftools/src/bcftools-1.3/Makefile 2016-03-05 11:24:58.512091814 +0100
-@@ -28,18 +28,8 @@
+diff -aur /tmp/makepkg/bcftools/src/bcftools-1.3.1/Makefile /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched/Makefile
+--- /tmp/makepkg/bcftools/src/bcftools-1.3.1/Makefile 2016-04-22 11:50:59.000000000 +0200
++++ /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched/Makefile 2016-05-29 20:18:22.323268586 +0200
+@@ -28,18 +28,10 @@
all: $(PROG) $(TEST_PROG)
-# Adjust $(HTSDIR) to point to your top-level htslib directory
--HTSDIR = htslib-1.3
+-HTSDIR = htslib-1.3.1
-include $(HTSDIR)/htslib.mk
-HTSLIB = $(HTSDIR)/libhts.a
-BGZIP = $(HTSDIR)/bgzip
-TABIX = $(HTSDIR)/tabix
--
++HTSDIR = /usr/include
+
CC = gcc
-CPPFLAGS =
-CFLAGS = -g -Wall -Wc++-compat -O2
@@ -20,7 +22,7 @@
OBJS = main.o vcfindex.o tabix.o \
vcfstats.o vcfisec.o vcfmerge.o vcfquery.o vcffilter.o filter.o vcfsom.o \
-@@ -48,7 +38,7 @@
+@@ -48,7 +40,7 @@
vcfcnv.o HMM.o vcfplugin.o consensus.o ploidy.o version.o \
ccall.o em.o prob1.o kmin.o # the original samtools calling
@@ -29,7 +31,7 @@
GSL_LIBS =
# The polysomy command is not compiled by default because it brings dependency
-@@ -57,7 +47,7 @@
+@@ -57,7 +49,7 @@
ifdef USE_GPL
EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o
@@ -38,7 +40,7 @@
endif
prefix = /usr/local
-@@ -101,11 +91,11 @@
+@@ -101,11 +93,11 @@
.c.o:
$(CC) $(CFLAGS) $(EXTRA_CPPFLAGS) $(CPPFLAGS) -c -o $@ $<
@@ -54,64 +56,7 @@
# Plugin rules
-@@ -136,20 +126,20 @@
- filter_h = filter.h $(htslib_vcf_h)
- ploidy_h = ploidy.h $(htslib_regidx_h)
- prob1_h = prob1.h $(htslib_vcf_h) $(call_h)
--roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kstring.h $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
- cnv_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h)
-
- main.o: main.c $(htslib_hts_h) version.h $(bcftools_h)
--vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
--vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
--vcfcall.o: vcfcall.c $(htslib_vcf_h) $(HTSDIR)/htslib/kfunc.h $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/khash_str2int.h $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
--vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
-+vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
-+vcfcall.o: vcfcall.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
-+vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
- vcfconvert.o: vcfconvert.c $(htslib_vcf_h) $(htslib_bgzf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h) $(tsv2vcf_h)
- vcffilter.o: vcffilter.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) rbuf.h
- vcfgtcheck.o: vcfgtcheck.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
- vcfindex.o: vcfindex.c $(htslib_vcf_h) $(htslib_tbx_h)
- vcfisec.o: vcfisec.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
--vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h $(HTSDIR)/htslib/khash.h
-+vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h
- vcfnorm.o: vcfnorm.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_faidx_h) $(bcftools_h) rbuf.h
- vcfquery.o: vcfquery.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h)
- vcfroh.o: vcfroh.c $(roh_h)
-@@ -157,22 +147,22 @@
- vcfsom.o: vcfsom.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
- vcfstats.o: vcfstats.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(htslib_faidx_h) $(bcftools_h)
- vcfview.o: vcfview.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
--reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(bcftools_h)
- tabix.o: tabix.c $(htslib_bgzf_h) $(htslib_tbx_h)
--ccall.o: ccall.c $(HTSDIR)/htslib/kfunc.h $(call_h) kmin.h $(prob1_h)
-+ccall.o: ccall.c $(call_h) kmin.h $(prob1_h)
- convert.o: convert.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(convert_h)
- tsv2vcf.o: tsv2vcf.c $(tsv2vcf_h)
- em.o: em.c $(htslib_vcf_h) kmin.h $(call_h)
--filter.o: filter.c $(HTSDIR)/htslib/khash_str2int.h $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
-+filter.o: filter.c $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
- gvcf.o: gvcf.c $(call_h)
- kmin.o: kmin.c kmin.h
--mcall.o: mcall.c $(HTSDIR)/htslib/kfunc.h $(call_h)
-+mcall.o: mcall.c $(call_h)
- prob1.o: prob1.c $(prob1_h)
- vcmp.o: vcmp.c $(htslib_hts_h) vcmp.h
--ploidy.o: ploidy.c $(htslib_regidx_h) $(HTSDIR)/htslib/khash_str2int.h $(HTSDIR)/htslib/kseq.h $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
-+ploidy.o: ploidy.c $(htslib_regidx_h) $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
- polysomy.o: polysomy.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) peakfit.h
--peakfit.o: peakfit.c peakfit.h $(htslib_hts_h) $(HTSDIR)/htslib/kstring.h
--consensus.o: consensus.c $(htslib_hts_h) $(HTSDIR)/htslib/kseq.h rbuf.h $(bcftools_h) $(HTSDIR)/htslib/regidx.h
-+peakfit.o: peakfit.c peakfit.h $(htslib_hts_h)
-+consensus.o: consensus.c $(htslib_hts_h) rbuf.h $(bcftools_h)
- version.o: version.h version.c
-
- test/test-rbuf.o: test/test-rbuf.c rbuf.h
-@@ -180,8 +170,8 @@
+@@ -180,8 +172,8 @@
test/test-rbuf: test/test-rbuf.o
$(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS)
@@ -122,3 +67,5 @@
doc/bcftools.1: doc/bcftools.txt
cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt
+Only in /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched: Makefile.orig
+Only in /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched: Makefile.rej