summarylogtreecommitdiffstats
path: root/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefile.patch')
-rw-r--r--makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..8e76c067989a
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 3fd68d1d..cd4afa61 100644
+--- a/Makefile
++++ b/Makefile
+@@ -404,7 +404,7 @@ LIBRARY_DIRS += $(LIB_BUILD_DIR)
+ CXXFLAGS += -MMD -MP
+
+ # Complete build flags.
+-COMMON_FLAGS += $(foreach includedir,$(INCLUDE_DIRS),-isystem $(includedir))
++COMMON_FLAGS += $(foreach includedir,$(INCLUDE_DIRS),-I$(includedir))
+ CXXFLAGS += -pthread -fPIC $(COMMON_FLAGS) $(WARNINGS)
+ NVCCFLAGS += -ccbin=$(CXX) -Xcompiler -fPIC $(COMMON_FLAGS)
+ # mex may invoke an older gcc that is too liberal with -Wuninitalized