summarylogtreecommitdiffstats
path: root/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefile.patch')
-rw-r--r--makefile.patch8
1 files changed, 6 insertions, 2 deletions
diff --git a/makefile.patch b/makefile.patch
index c60736d50d62..2cc2bd6d94b1 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,11 +1,15 @@
--- a/Makefile
+++ b/Makefile
-@@ -35,7 +35,7 @@ distclean:
+@@ -36,7 +36,7 @@ distclean:
install: all
install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(sysconfdir)/dbus-1/interfaces/$(RDD).xml"
- install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
+- install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
++ install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(datadir)/dbus-1/interfaces/$(RDD).xml"
+ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(datadir)/dbus-1/system.d/$(BIN).conf"
- install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
++ install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(libdir)/systemd/system/$(BIN).service"
install -D -m 0644 "data/$(POLICY).policy" $(DESTDIR)$(datadir)/polkit-1/actions/$(POLICY).policy
+ uninstall: